Skybell Slim fails at Installation

Hello,

I am having trouble getting the Skybell Slim to connect to WiFi.

I am having a similar issue as this user and have tried all the suggestions here:

I’ll summarize what I’ve done so far:

  • Installed Skybell hardware and powered on
  • Followed instructions on ADC app to add Skybell Slim
  • Light was blinking red and green. Disabled cellular data. Connected to Skybell_xxxxxxx network in wifi settings as per app instructions. Returned to app. Selected the network I wanted to connect to (2.4 GHz, b/g/n, unique SSID). Tried auto-connect first. Installation fails at 10%, light blinks orange.
  • Power cycled router/modem.
  • Attempted to connect again, same result.
  • Tried connecting again, this time with manual setup and assigning Skybell’s static IP. Same result.
  • Factory reset the Skybell (blinking yellow), same result.
  • Checked to make sure MAC filtering was off. Didn’t see options for the other two suggestions along with the MAC filtering.

My router is a Netgear AC1200 (R6220). The router is about 10-15 feet away from the Skybell with only the front door obstructing the LOS. Routers firmware version is v1.1.0.100_1.0.1. ADC app is up to date.

Not sure where to go from here… Possible I may need a range extender?

Well good news, looks like it was a range issue. I ended up using the Qolsys Panel as a WiFi Access Point and had success adding the camera.

Good to hear you were able to resolve the issue! Is it still working well for you now?

Still working well, thank you. I am wondering now though, is there a way to hide my panel’s SSID from being broadcasted?

That’s a great question, currently no, there is no way to disable the SSID broadcast other than disabling the access point. I’ve requested this as a feature from Qolsys however. Hopefully we will see this option soon!