Problems with ADC-VDB770 Doorbell


We’re having problems with our ADC doorbell. It’s been stuck on red and will not reset. We tried taking it off and the light remains red even after removing from the plate. We tried holding down the button for 1-2 mins and it does not reset. Can you help us troubleshoot? It’s still under warranty.

Solid red LED indicates No local or Internet connection.

If you hold the button down for 40-45 seconds it should blink yellow, this is a power cycle. Do this while connected to power (connected to the base plate). Does the LED change at all?

Removing the camera from the baseplate will eventually drain the internal battery.

On the back of the camera you should see a label, is it sitting flush or is it being pushed out? Feel free to post a picture

Some helpful guides:

The color does not change when pressing the button while attached to the plate.

I’ll send a picture of the back to you directly.

Thank you, the image has been received.

At this time, disconnect the camera from the back plate and connect it to power via the micro usb port. Then try to reboot, any change?

If not, you may need to let the backup battery drain, re-apply power and check whether the camera is stuck in that state still. Please let us know what you find.

Tried the mini USB and it didn’t reset. Still stuck on red.

Letting it drain now and will try to connect, per your instructions.

Doorbell is now reconnected and working. Problem now is that the chime inside isn’t working. The settings are all the same, so now sure what happened. We do get the notifications on our phones when the doorbell is pushed, but we don’t hear it inside.

That is normal if you have let the battery drain down and then powered back up. The battery needs to be at a sufficient voltage to engage the chime. Allow a little time to charge and this should resolve. Let us know if it does not.