PowerG not working on IQPanel4

My new IQPanel4 won’t read in any PowerG sensors while in auto learn mode under PowerG. I took a PowerG sensor to another system I have and it enrolled immediately. I’ve tried auto learning it, enrolling it manually and using the QR code scan. For the manual and QR code scan I get an error when I hit “pair” that says “invalid code”. Any idea what this could be?

That is frustrating. I assume when you tried enrolling them manually you made sure to choose PowerG and not 319.5?

The support team will be back online Monday morning and they would need to help with detailed troubleshooting or a sending a replacement panel if necessary.

Yes, the interface won’t accept the sensor ID (xxx-xxxx), keeps giving me an invalid code error.

Ok, after 10 hours of struggling this weekend, here is what I’ve observed:

  1. The auto learn for PowerG does not work with any type of sensors. I have tried 10 different sensors and all 10 of the sensors auto learn on my alternate panel. It appears that auto learn for “automation” never turns on.
  2. All of the PowerG devices I am able to read in via manual entry do not work properly. They take a loooong time to connect, they randomly turn on and off. In the case of the PowerG switches, one won’t turn off ever and one won’t stay on ever. When I remove them from the system, they work normally (like a regular wall switch).
  3. When manually adding “automation” devices, the panel will auto-populate some data from the 3-digit code (example: when I type 510 it defaults to “lights”) and it doesn’t recognize other 3-digit codes (example: when I type 502 for door locks it does not recognize the code) and gives an “invalid code” error.
  4. Some PowerG sensors (example: CO monitor) loses connectivity even when it is sitting right next to the head unit. Other PowerG sensors act erratically.
  5. When I run the PowerG test, different devices report lost connectivity with no change in position or programming.

This appears to be a bad PowerG board or the firmware didn’t load property.

Next steps?

It looks like the system related to this is reporting 4.3.0 firmware.

PowerG automation devices require 4.4.0+ firmware on the panel to be compatible.

With incompatible devices connected it is likely that the radio is encountering problems and this may affect signaling reception of other PowerG sensors.

First delete all PowerG devices, then update the firmware via the steps here:

Then relearn your devices. Does this resolve the odd behaviors?

Yes. This weekend, I checked for software upgrades multiple times. I would have never known which was the correct patch to have loaded. Where can I find this information in the future?

If you choose to watch that firmware update thread using the bell icon, new posts will result in notifications when firmware versions are available.

A description of the changes and supported devices are included in each post.

Unfortunately Qolsys has been requiring patch tags for most firmware updates since about mid way through the IQ Panel 2 run.