motion sensor false alarm

When the house security system is set to “Away” there are two ways we have to enter the house:

  1. disarm the system from a phone before opening the front door
  2. open the front door, hear the “beep, beep”, disarm it from the panel by entering the code

Recently we started experiencing a problem with #2: when we open a front door, we hear “beep, beep”, but as we are walking towards the panel a motion sensor triggers the alarm.

Did anything change firmware wise? (2GIG / GC3) Are there any new “” policies? Anything we can do on our end to not have these “false alarms”?

Sometimes it is too cold outside, and it is not convenient to take off gloves, get a phone out and wait outside until the system is disarmed.

We’ve actually heard a couple reports of GC3 firmware 3.2 causing an apparent bug in the way the panel handles existing interior follower sensor reports.

Typically interior followers (like motion detectors) are ignored during entry and exit delay otherwise arming and leaving or entering and walking to the panel to disarm would cause an alarm. (like what you are seeing)

One of the other users who saw this said this was resolved by troubleshooting. The steps they took were deleting and reprogramming the motion detector zones and power cycling the panel.

I haven’t been able to replicate this issue to confirm which step resolves the issue. I would suggest trying just a power cycle first, then test. Any change?

If not, delete the sensors, reprogram, then after saving the changes wait a minute and power cycle the panel. Does that resolve the issue?

power cycle the panel

what is the correct course of action not to trigger an alarm: i.e. take out the battery first, and then unplug? (then plug in and reinsert the battery)?

Always unplug the transformer first, then open the panel and unplug the battery. Wait a minute, then plug in the battery, close up the panel, and plug in the transformer.

I just wanted to chime in that the exact same thing started happening with my GC3 in December, too. I’m running 2GIG GC3 Firmware 3.2. I’ll try to power cycle tomorrow without removing the sensor and see if that clears up the issue over the next month. I’ll report back then, but hopefully a new firmware will fix this.

in my case a power cycle did not help
not sure whether I need to downgrade, or… wait for a firmware patch?

After it failed to correct the problem, did you try deleting and re-adding the motion detector? Maybe I’ll just try that first.

have not tried that.
let us know if it works.
family is asleep: i.e. not the best time for me to play with the alarm.

Another user had reported that deleting and re-adding the motion detector resolved the issue. Try deleting the zone and relearn when you get a chance and let us know if you notice a change.

I removed and re-added the sensor last night. Now we’ll wait and see (I only had the issue happen about once a week before.) I’ll keep everyone posted.

Bad news: removing and re-adding the sensor and power cycling the GC3 did not fix the issue. It just happened to be again. The motion detector trips the alarm as I punch in the disarm code.

Thank you for following up. Can you confirm the exact programming of the zone in question?

I do think this is a firmware bug, just want to be able to send to 2GIG exact details.

Also is this on smart areas? have you tried setting it in a different partition? any difference?

Attached are the config of the sensor. I’m not sure what you mean by smart area or partition. I don’t believe I use any in addition to the default ones.

In your image, see where it says “Smart Areas Assignment?”

Smart Areas (just 2GIG renaming Partitions) is a method of arming different areas of a home or business independently. The latest GC3 firmware supports up to 4 partitions.

I am curious if there is any difference in operation of the motion detector if you place it in partition (smart area) 2.

After, arm both partitions and test. Any change?

I just set it to #2 and will test over the next week to see if it happens again.

So it’s been behaving since I changed it to Smart Area #2, but I checked my phone today and noticed it’s because area 2 has never been arming when I arm the system from the panel. I tried arming area 2 via the phone, and it fails saying “Partition 2 reported a failed arming”. Any idea what to do about the failed arming from phone, and how to make area 1 AND 2 arm when I hit Arm (away) on the panel? Once I do that, I can see if that fixes the original problem. Thanks!

Any idea what to do about the failed arming from phone, and how to make area 1 AND 2 arm when I hit Arm (away) on the panel?

To arm the various smart areas, you would need to tap the “Smart Areas” button on the home screen, enter your password, and arm the desired areas. All available smart areas will have an away and stay arming option.

As far as the failed arming is concerned, do you have any other zones on S2?

Have you enabled Smart Areas in panel programming? You can set sensors to use a certain smart area, but you will need to go to System Settings > Installer Toolbox > System Configuration > Panel Programming, then enable Q69.

Opps, I didn’t have them enabled in Q69. I enabled it and will try arming both areas over the next week and report back. Thanks!

Well, no luck. I just walked in and the motion detector triggered the alarm instantly while I still had time to disarm it. Granted this might be different than the original issue now and maybe I just don’t know how to use the smart area feature. Is there a separate option to set entry delay for area #2?

Ah, yes, my bad you would want to try setting the entry sensor to Smart Area 2 as well and arming just Smart Area 2. Walk in through that entry sensor, does the motion detector cause a false alarm? (be sure to wait outside after arming for a few minutes to ensure the motion detector has reset)

The test is to determine if the bug affects just the first Smart Area or all of them.