ADC-VC727P not connecting

Hello, I just bought a ADC-VC727P and when I connect it through POE it just stays blinking green. There is also no option to add this specific device in the alarm.com app either.

I tried adding it using the MAC address but the app cant find it.

For reference I have a ADC-VC838PF that I connected earlier this year with no issues through POE.

I already tried resetting the camera to factory default via the button on the bottom. I also power cycled the camera and my router multiple times.

Any help would be appreciated

Blinking green indicates it can only communicate on the LAN. It has no internet connection. This typically means the nat/firewall settings are not allowing traffic to/from the camera.

What model of router are you using? Did you add any rules for the other camera when you set it up?

Thanks for the reply Jason,

I have a TP-Link AC1750.

I did not have to make any rules for the other camera. It just connected right up.

Are all PoE cameras directly connected to that router?

Was this camera new or used?

Hey Tyler,

Yes, both PoE cams are conected to the same router. This was a brand new sealed camera.

If you have alternate ports, try connecting the camera to a different port. Any change?

Tried that, even disconnected the camera that is working and used the port it was on. Still not connecting.

Is the camera physically installed right now or are you using a short patch cable to pair it first before installation?

I would recommend bench testing if you are not, with a short patch cable just so there is no question about the wiring, though I wouldn’t expect the blinking green on most cabling issues. Does it work using POE on a short patch cable?

If not, does it work using the barrel connector and power supply, not using POE?

It would be very strange for there to be router issues on one ADC camera and not the other. It makes me suspect the camera itself is the underlying issue.

Camera was installed but I took it down to bench test it.

Used 3 different cables to test it with the same blinking green light result.

Unfortunately the camera did not come with a power supply and I don’t want to buy one.

I think I agree that the camera itself may be the issue.

Any other suggestions before I initiate a return?

Could you maybe suggest an alternative camera that is also POE for outdoor patio use? Or is the ADC-VC727P a good choice?

Thanks

Did you make any router changes, add any alternate devices, or update the router firmware in between installing the first camera and trying the second? Or were they added at the same time? A list of some POE capable models are below. I would think the VC727P would be a good choice, but any from the list below might work.

I did not make any router changes or updates. Nothing was added between adding the first camera. The first camera was added about 2 months ago.

Would alarm.com be able to replace or fix the camera for me? Do they have some type of warranty? What is the email/procedure?

Thanks

Warranty agreements are between the vendor and buyer, be sure to reach out to the vendor where the camera was purchased for details on how they handle warranty.

For the sake of posterity, I wanted to update that I reached out to the camera vendor who put us on a three way call with an Alarm.com tech that deemed the device defective. A full refund was issued.

Thank you for following up and confirming!

Check to see which package you have and how many cameras can be added to your account. You might to upgrade your alarm.com package to add extra camera
And once you upgraded it
Then check if the camera came up on your phone.