Zwave devices with Qolsys IQ Panel 2 and SmartThings Hub

I currently have my Qolsys IQ Panel 2 setup as the primary Z-Wave controller and my SmartThings Hubv2 as the secondary and it’s been working well for almost 2 years. When I added my 21’st Z-Wave device, it did not show up in SmartThings like the previous 20 did. I’ve tried unpairing/re-pairing, I’ve selected the option to “Manage Devices from Secondary Controller” on the Qolsys but nothing has worked. Is there a limit of how many Z-Wave devices the Qolsys can sync to a secondary Z-Wave controller like SmartThings?

Looking into this issue further as I am unable to test. Reached out to Qolsys and may have more information for you.

What is the device type/name that you last attempted to add?

If you go into settings - advanced settings - Installation - Devices - Zwave devices - Zwave settings - Under Device Limits you can select the number of devices you would like. Does changing these solve your issue?

In version 2.3 the z-wave device limit breakdown is as follows:

10 Thermostats
15 Smart Sockets
20 Door Locks
80 Lights
21 Other devices
6 Garage Doors

The device name is “master bedroom fan”. The device limits on mine are similar (I’ve tried increasing them as well), but the device is still not being sync’d to SmartThings.

Commands have been sent to sync devices at this time. It does appear that the device is showing up in

Have you run a Z-Wave network rediscovery? and Its still not showing up in the ST hub?

I’ll have to do some more digging as I do not have an ST to test.

Yes, the device shows up in and can be controlled through the mobile app or on the panel. I just ran a Z-Wave network rediscovery and the device has not shown up in SmartThings.

Any update from Qolsys regarding this? I’ve tried adding new devices and those devices aren’t sync’d to SmartThings either.

Still awaiting additional information regarding any set limit etc.
However, removing and re-adding the secondary panel should cause devices to resync and be shared.

I tried remove the secondary panel and it kept saying it was removed successfully, but the devices never disappeared from SmartThings. I then tried to clear the SmartThings Hub from the IQ Panel 2 and this ended up somehow clearing all my Zwave devices from the panel. Not sure how that happened but SmartThings was still able to control all of my Zwave devices. From what I’ve seen online, it may not be possible to make the SmartThings a secondary controller anymore which would explain why the sync with the IQ Panel 2 stopped working.

Also after I re-added all my Zwave devices to the panel I’m having an issue with a remote thermostat. One of them will not let me delete it (it was not added correctly). Could you delete the thermostat labeled “Failed Device” on my account? Also is it possible to send a sync command to the thermostat labeled “Maddy’s Bedroom”? That device reported the temp once and has not updated since (I’ve tried hitting the button on the temp sensor and the light just blinks). THANKS!

Unfortunately unless the panel reports an error to for that specific device we cannot send remote deletion commands (nor would they work).

I’ve sent an update status command to the panel and all devices except for the one labeled Failed Device are reporting proper neighbor node info, however this did not spur the panel to report a malfunction on the temp sensor.

The update command applied as well to the Maddy’s Bedroom temp sensor, which should be functioning normally at this time.

When you say the one temp sensor cannot be deleted locally, what issue are you seeing when performing the steps? Is the panel not recognizing that the device button is being pressed while searching for devices to clear? Have you tried bringing that temp sensor close to the panel and going through the Clear Device process?

I was able to delete the sensor labeled Failed Device. I had to remove the batteries from the downstairs thermostat (adc-T2000) which allowed me to remove the failed device (remote sensor).

I was able to get all the sensors working and since they are still reporting the temp, I appears they are still working but all 3 sensors show failed now in (this occurred about 24 hours after they were setup). Not sure why they report they are failed.

Regarding my initial Zwave pairing question, I was able to get the Zwave switch paired with SmartThings by adding it to SmartThings separately. Now both the IQ Panel and SmartThings can control the device. Going forward I’ll add new Zwave devices to the IQ Panel 2 then add it again to SmartThings.

When you learned the temp sensors in were they in their permanent locations? They need to be. If learned up close and then moved they will have signaling issues due to the fact they do not participate in Rediscovery and only learn in via network wide inclusion.

They were learned in their final destination. The sensors work, I can see each sensors temperatures in the mobile app and the temps change throughout the day so it seems like the sensors work properly. I figured if they were failed as the error states on the web, I should be able to delete them from the panel, but when I attempted to remove them it said it could still communicate with the sensor and wouldn’t remove it. I did not clear the device and re-add since the sensors still works but that maybe the next thing I try.

I did not clear the device and re-add since the sensors still works but that maybe the next thing I try.

Clearing and re-adding would indeed be the best next step if you are seeing malfunctions. Any luck?

I cleared all 3 remote thermostats and re-added them. They currently report the temperature with no issues but after about 24 hours of being added back, is reporting them as failed again. How can I resolve this?

All three RTSs are reporting malfunction which indicates that they have not successfully communicated with the panel in about 24 hours.

First troubleshooting step to do is to delete and re-add the RTSs to the network which appears to have already been done

Next look at nearby repeating z-wave nodes, how close are the nearest repeating nodes and how far away is the panel from the RTSs?

The 3 RTS are in the same location they have been for the last ~2 years. They are each located in a bedroom and each bedroom has 2 Zwave GE switches (1 for the light, 1 for the fan) which are within 5 ft of the RTS. Two bedrooms are next to each other on the second floor (with a bath in between) and 1 bedroom is on the first floor. The panel is on the first floor as well. The panel to the 1st floor RTS is about 25ft with multiple Zwave devices in between.

What doesn’t make sense to me is why all 3 RTS devices are updating with the current the temp for each room in the mobile app. I can see the temps change for each RTS device. I would expect that communication to be going through the panel but don’t understand why the RTS devices would report a malfunction in ADC if the temps are changing in the mobile app.

It sounds like the Z-Wave mesh network is quite robust, which is always helpful.

The RTSs are currently reporting as offline in the ADC website, are they currently reporting this way in the ADC app? If you log out, then back in to the app, are they still reporting current temperature?

It is odd that all three RTS are reporting a malfunction. They are roughly two years old? Are the RTSs using the original batteries? The batteries may be low/borderline low which could cause a malfunction, if that’s the case. Can you test the battery with a multi-meter? Do you have extra new CR123s to test?

I logged out of the app and back in and was able to see the temps of the RTS. I tested the battery and it showed 2.95v. I luckily had a new CR123 as well so I swapped the battery and still malfunction did not clear.

I also went into the panel’s Zwave Diagnostic screen (System Tests | Zwave Tests | Zwave Diagnostics) and I could see on a map all the Zwave devices with color coded signal strength and who they were communicating with including the RTS’s. I then went into Advanced Zwave Diagnotics | Network Health Test and ran the test on each RTS and it showed their neighbor info etc. I also went into Last Working Route and selected each RTS and could see which Zwave device they communicated with last. I selected Edit and chose closer Zwave devices, then went back to Zwave Diagnostics and could see the RTS was now communicating with the Zwave device I chose.

After all this, the RTS is still reporting the temp in each room it’s located in through the ADC app. The app still shows 3 issues (malfunction of the RTS) but on the main page under Thermostats if I choose the down arrow I can see the updated temps. If I click on Thermostats from the main page and click on Temperature Sensors, I then see ? marks for each RTS but the temp is accurate.

I luckily had a new CR123 as well so I swapped the battery and still malfunction did not clear

At 2.95V they would need to be replaced. When swapping batteries, the malfunction may not clear immediately. Its a good idea to leave the device powered down for a couple minutes before adding the new battery and powering back up.

Regarding the mobile app disparity, it is possible that the app is showing the temp the RTSs last read. Are you able to post a screen shot of the RTS temps in the app? You can also send it to if you would like.