Z wave outlet for light works on panel but not remotely

I recently installed a Qolsys Panel 4 & Hardwire 16F in my mother-in-laws home to take over an old wired alarm system. Seems to be working well in that regard.

I have added two Z wave outlets (Aeotec Smart Switch 7) to control lamps. I can reliably turn the outlets/lamps on locally at the panel, but not remotely via the alarm.com website. Interestingly, these outlets each appear locally on the panel as two nodes: one seems to be simple on-off, the other seems to have dimming capabilities. I can turn them on and off locally at the panel using the on/off mode; the dimming node has no effect. On the alarm.com website, only the dimming node is shown, and so turning the lights on/off remotely has no effect (although I do see that the dimming node is turned on at the panel after a remote activation). So how do I get remote activation via alarm.com to use the non-dimming node ?

I have sent some commands to update the Z-Wave equipment list and resync deivces. The following two are showing up in Alarm.com:

  • Master Bedroom Light
  • Living Room Light

You may need to log out of your ADC account and then log back in to see these devices. You should be able to control them through the app at this time however. Can you?

Thanks, but still not working. I am interacting via a web browser on alarm.com not the app. At this point when I remotely turn on the light I still still see the dimmer node in the browser, but now on the panel it indicates the non-dimming node is turned on, but still no light. I can still turn the lights on an off just fine at the panel itself.

Sending you some photos of what I am seeing via email.

Of the two devices, which one is not working correctly?

Neither turns on remotely. Both turn on fine locally from the panel.

Sent you pictures to help illustrate what I see.

As I noted in my response, different but still not working.

What I see on my panel:


What I see after remotely turning on the living room light in the web browser:


And on the panel:


But the lamp is not on.

Not seeing that email. Did you send it to support@suretyhome.com?

You can attach pictures here as well, or send us pictures/support requests to keep them off the public forum too.

However, the Smart Switch 7s are not listed as tested compatible by Qolsys, which may be part of the issue here.

What I would do next is:

  • clear both devices from panel programming
  • factory reset each switch.
    • Pressing and holding the learn button for 20 seconds or more. Fades blue LED in and out slowly
  • Add one switch back in via panel programming.
    • Only one instance of the switch should appear.
  • Once one is added, run a Z-Wave network rediscovery.

Does the switch show up in ADC? If so, can you control it remotely?

If so, add the second switch, re-run the z-wave network redsicovery and test the second one.

OK, removed all Z wave devices and factory reset both switches (flashing blue).

Added only one outlet back in (using Smart Start and immediately added to network when it powered up)

See two nodes on panel; can send picture via email. Can locally turn on/off lamp at the panel using the non-dimming mode.

Alarm.com webbrowser sees light, but presents it as a dimming node (can send a picture). Turning it on via web browser has panel indicating non-dimming node is turned on; but the lamp is not on.

Panel after adding one outlet back in:


Web browser interface for light:


Remotely activate the light, and see this on my panel:


But lamp is not on. Yet I see this same panel indication if I turn the light on at the panel and the lamp works.

If you navigate to Settings > Advanced Settings > Installation > Devices > Z-Wave Devices. > Edit Sensor, how many devices show up in the list currently?

One. ID 6 Type Light Name Light

Are those the only 2 Z-Wave devices you have to test?

Yes at the moment those are the only two I have.

Ive Reached out to Qolsys to see if those devices have been tested at all, unfortunately, I do not have one to test atm.

Have you used smart start to add the deivces each time? Try manually doing it (after clearing first). Any change?

Actually I did add one switch manually; and the results were the same.

I am considering using the panel’s local automation to turn these on/off until this gets sorted out. Can you tell me what hours the evening setting is activated ?

Sent a private message.

Still waiting on follow up information from Qolsys at this time. I will follow up here with any additional troubleshooting steps.

Can you tell me what hours the evening setting is activated ?

Evening: Turns light on at 7pm and off at 11pm

Qolsys indicates that the above steps would be recommneded to resolve, however they also state that the Aeotec Switch 7 has not been tested for compatibility and is not officially supported at this time. This is likely the issue but I am still investigating to see if there is anything that has been missed.

How far away was the switch when you learned it in to the panel?

Thanks for the info. I have enabled “Local Automation” on the panel. That option has some interesting text associated which indicates that the “first light will be turned on at night and all lights will be turned off in the morning”. This seems at odds with the choice of day versus evening versus night I saw when adding the light. I’ll observe what happens tonight.

Also, further investigation on my part reveals the following: referring back to the pictures I shared showing Light(6,1) and Light(6,2) with Light(6,2) appearing as a dimming node, I found that activating Light(6,2) turns on the night light feature on the side button of the smart switch when the attached lamp is turned on (via activating Light(6,1)). Not sure why Light(6,2) appears with a dimming icon.

I understand Qolsys may maintain that the Aeotec 7 is not yet officially supported, but it does work fine locally on the panel. Just not remotely.