Vivint takeover problem

I purchased an AT&T 3G cell module, updated firmware to v1.13, and after installing the new cell module, my Vivint go panel does not recognize that there is a cell module present. The option of doing a cell test is not available on my panel. Any suggestions as to why the new cell module is not being recognized? Thanks in advance.

Is this a panel that previously worked, or is it something you bought off eBay?

Is the cell also something you bought off eBay, or did you buy it from a legitimate ADC dealer?

The option for cell test is missing? Have you performed a panel reboot?

Does cell module have the proper antenna (the long 12" “in the wall” antenna)?, Is cell properly seated into socket? powered down, then powered back up panel following module install?

If a compatible cell module is properly installed, but you do not see the cell test button, either the panel is damaged, cell module is damaged, or you didn’t reboot following install of module, or Q91 is (0) “disabled” (Q91 needs to be set to “1”)

Access cell test on a locked out panel:
Menu/toolbox/master code/right arrow/right arrow/cell phone test/enter master code

Thanks, rive. The panel was working fine. My contract with Vivint is expiring so I am trying to do the takeover. The AT&T module was purchased from suretyDIY. The firmware was 1.9.6 but I updated it to the most current 1.13 before installing the new cell module since the instructions that came with it said to update to the most current version. I have unplugged the panel from electric and unplugged the battery if that is what you mean by doing a reset. The antenna is the one that was provided by suretyDIY with the module and is the same kind that was attached to the working Vivint module, but it is the one that is inside the panel.

The cell phone test option is missing in your picture when I try to do that part of it. Is there a way to set Q91 from the panel?

Thanks for the help.

You should not have to reset Q91 if it was previously working. It should already be set to “1”. In any event, you need installer access to change it.

You should have activated cell before updating firmware. Anything 1.9.6 or above is sufficient

Power down, do a pic of module/antenna

Take out cell module, check to see if the pins are bent, reinsert it. Power up, then power down, and back up again. See if cell test button appears.

If afterwards, there is no cell test button, then I suspect you may have inadvertently damaged something/got bad module.

If your panel successfully updated to 1.13 firmware then the problem would either be:

  1. The cell module daughter board isn't seated properly on the mother board.
  2. The cell module is damaged.
  3. The main control panel is damaged.

Try this:

  1. Power down (wall and battery).
  2. Remove the new cell module.
  3. Wait a minute.
  4. Re-install the new cell module.
  5. Power back up

Whether or not the antenna is installed properly won’t matter in the case. Even with the antenna unplugged you would still see the radio status section in installer mode.

If the steps above to re-seat the cell module don’t work then you might try re-installing the older cell module to see if the radio status shows up in installer mode with that one. If it does, then the new cell module is probably damaged/defective and needs exchanged.

Thank you for the replies. Here are a few pictures. I powered down, took out the module, put it back in, and still don’t have the cell phone test option. The old Vivint module is no not working either. If that means that the control panel is damaged, should I return the new cell module I purchased from suretyDIY and get a panel with a module already included? If I have to replace the module, is there an easy way to learn the sensors and z-wave devices to the new panel? Thanks again!!!

Also, on the home screen, the Vivint logo is still present. Does that make any difference?

powered down, took out the module, put it back in, and still don’t have the cell phone test option. The old Vivint module is no not working either

Panel may be damaged, and will have to be replaced. You probably damaged it during the firmware update, or during installation/removal of cell module.

The panel is still locked out/shows Vivint logo because you never successfully completed a cell test so as to reprovision the panel with new provider.

Be more careful next time. It is very easy to damage the MB if you don’t know what you are doing.

Panels and modules are sold separately, so you would not need to return the module if you do need a new panel. (On our site, there is a drop down choice for the panel that allows you to pick no module, Verizon module or AT&T module- so you would just pick no module.)

Yes, you can learn in new sensors and z-wave items. Do you have specific questions about any sensors? We have some videos showing the process for different sensors, there are directions available for most equipment (that are usually fairly straight forward) and we’re available here on the forum if you still have questions. Some examples that may give you a better idea of what is involved.

The suretyCAM logo won’t show up on your screen until after a successful cell phone test is run and the update it initiates completes.

For future reference, this is NOT how the antenna is supposed to be installed.

There is a tab on the back wall plate marked “Antenna” that the antenna goes into (and in wall).

Is that how the antenna was done by the person who originally installed the panel?

Thank you all. I will order a new panel. The antenna was installed the same as it was done by the Vivint install tech and had worked that way for the 4+ years that we had the system, so I just installed it the same way. I will be sure take extreme care with the new panel. Thanks again, all, for your help figuring this all out. I appreciate it.

I wonder if that antenna wire may have come in contact with something that may have shorted/surged the cell module board…

That’s what happened to my old panel, it broke at the antenna connector, I tried to repair it, and inadvertently damaged the motherboard, necessitating a replacement panel.

The panel is probably toast (since the vivint cell no longer works), and the module may be toast now too…

Oh no. I hope the cell module isn’t damaged now too. Hopefully, once the new panel arrives, it will work. I will be sure to install the antenna in the wall the way that it should have been done from the beginning.

I suspect the cell module is damaged (if it caused damage to the main panel board, logic dictates it may itself be damaged).

I am no electronics expert, but I am thinking blown resistor, diode, capacitor… something like that.

One other thing… never mess with, remove, etc, anything on the motherboard if it is still powered up. This includes transceiver, cell module, POTs module, firmware J4 update cable, etc.

We don’t know that the panel is damaged just because the old module didn’t show up. I have no idea if that old module is supposed to be detected by 1.13 firmware. That test would have only proven something if it did show up.

We do have a 30 day return policy so you can try it and send it back if you end up with something you don’t need. Just make sure you keep the equipment and packaging in tact in case you want to send something back.

I don’t see why the old module wouldn’t show up in 1.13

Its just a 2GIG 3G GC3GA module registered and locked to Vivint.

The GC3GA, and GCCDMV 3G modules were used exclusively in the 1.9.6 firmware 2GIG Vivint panels (which is also evidenced by the existing antenna)

Any 2GIG GoControl panel, set to Q91(1), with firmware at 1.9.6 or above should have no problem seeing the module.

I want to make sure I do this the right way. Based on what is known, how should I proceed? Order the new panel without a cell module and try the new cell module I already received from suretyDIY, or return that new cell module and get a new panel with the cell module already installed. Thanks, everyone.

Would it do any goo to try rolling back the firmware to 1.9.6? I was hoping to be able to use the geo-fence in the newer versions, but if I have to roll back to a previous version I could do that.

I think its a waste of time, but go ahead, roll back to 1.9.6, I suspect it will still not see either the vivint module or the suretyCAM module.

Other than that, the rest is up to you. If it were me, id get a new panel and module.

Ps- look at the vivint module (sticker), is it a GCCDMV-V (or GCCDMV-A), or a GC3GA-V (GC3GA-A) or a GSM1, GSM5, or GSM7 (or GSM2, GSM4, GSM6) module?

*If it is a GC3GA-T module, that means panel is not set to Q91(1), and no module will work with it.

*Highly unlikely as this (Q)uestion option did not exist prior to 1.10