Unable to pair z-wave devices

I am unable to pair z-wave devices. I tried with 4 different kind of devices (3 of them I was able to connect before).

Every time I try to connect a device, it finds it but hangs at the Querying Device Information part. After a while it times out and the device does not show on the list.

I have tried removing/ adding, rediscovering network, rebooting GC and even updating the firmware…but no luck.

Please help

What models of devices are you trying to pair?

Also, how far are the devices from the panel when you are trying to pair them?

Devices are next to the CP

I tried:

  1. aeon labs switch DSC06106-ZWUS (this was the first I tried and assumed it was defective) so I bought the new model:
  2. aeotec zw096-A02 new generation…this may not work bc is zwave plus then I tried an old switch that I used before with the system:
  3. GE ZW4201
  4. Finally I removed a zwave repeater from aeotec and tried to reconnect it DSD37-ZWUS

We’ve sent over a soft reset command for the Z-wave radio. Try adding a device in a few minutes (or when able) and let us know if there is any change.

Also, I see a device listed as a Controller type in the Z-wave device list. Do you have two controllers in this network? Is the 2GIG panel a secondary controller? If so, devices should be learned into the primary.

Hi Warren,

It did not work. That controller…I think it may be the minimote, I tried once but did not considered it very useful.
I think I may have it in a box somewhere, can I remove it from the panel without causing any harm?


Yes, you should be able to remove it. The minimote is typically just learned in as a device for scene control and association purposes.

Let us know if it is ok to send over a hard reboot command. Given the number of devices I would want to avoid defaulting the Z-wave network yet.

Hi Warren, you want to do the hard reboot before or after I remove the controller? if it is before, go ahead and do it, if it is after…let me know and I will remove it and update here.

After in this case would be preferable. We can see if either controller removal or the reboot has an impact.

I am unable to find the minimote, is there a way to remove it from the panel? Thanks

Sure, we may be able to remove remotely. Can you confirm the node ID for that device? If it is no longer communicating a remote deletion should work.

The node ID can be found by Services - Z-wave - Configuration Wrench - Installer Code - Advanced Toolbox - View all devices.


It is 82

I’ve sent a command to remove 82. Note that this will not take effect if the device is still communicating.

That didn’t work and I am having more issues. A few devices show as malfunctioning or that it does not recognize the manufacturer. I removed one from the network “dining table light” and attempted to reattach and I am not able to attach it.Please advice.

There seem to be some stresses on the 2GIG Z-wave network. We sent a syncing command requesting the Z-wave device list, and the panel reported a number of devices had been removed from the radio. A second equipment sync command re-populated those devices, seemingly having provided a partial prior list. Have you been removing and re-adding a lot of devices lately?

I cannot say for certain, but given the odd behavior, I am curious if the Z-wave radio is being taxed by the sheer number of devices.

One thing that can be tried is a firmware update. Looks like this is on 1.17 provides support for Z-wave radio command queuing, which may help with a larger network like this. 1.17 is only for the main panel. TS1s would not need an update from 1.16.

I tried to add a few devices a while ago multiple times. I see some of the missing / malfunctioning devices reappearing. I will upgrade the firmware and see if I can add the ones I disconnected.


seems that I lost the names of multiple lights, is possible to see the ID after you rename a device? I want to create a list of ID’s to device names. thanks

I upgraded the firmware and was able to add zwave devices again. I was going over the ones that was indicating malfunction and adding them, everything was looking great. Then I connected the panel and all the zwave configuration disappeared…there are no longer any devices connected…how did that happen? can it be restored?

I disconnected bridge and the cellphone antenna…in case is possible to push a backup from ADC

Then I connected the panel and all the zwave configuration disappeared…there are no longer any devices connected…how did that happen? can it be restored?

I’m a little confused on this. What do you mean you connected the panel? Are you saying you have a third party Z-wave controller and are using the 2GIG Panel as a secondary panel? Could you please clarify the steps that occurred?

I disconnected bridge and the cellphone antenna…in case is possible to push a backup from ADC

Z-wave pairing is a two-way link between the device and controller and must take place locally, Z-wave devices cannot be backed-up and restored through Alarm.com.

I was walking around the house with the panel disconnected from the wall, when I connected it to the wall the devices where no longer there.

No way to restore, ugh, what could have possible caused this?