TS1 won't relearn after firmware update

I successfully updated the firmware in my main panel to 1.12 (everything works fine, including the Schlage lock which prompted the update).

I then updated the TS1 to 1.10. This was a little less straightforward – after the update, the TS1 seemed to lock, so I reset it by pressing both front buttons. This triggered a reset/reboot, and it now seems to be working fine, with the updated firmware indicated.

However, the TS1 is no longer paired with the main panel. I attempted to relearn it several times, including disabling, saving, and re-enabling the TS1 in the main panel. No dice.

Any suggestions?

You cannot relearn a keypad/TS1 that is already learned/programmed. Just becuase you reset the TS1/unpaired it from panel, doesnt mean it is unpaired on the panel.

Remove/unlearn the TS1 from the panel programming, then reinstall/learn

To remove/unpair enter system config, goto Q4, then select TS1, set keypad as ‘unused’, save and exit programming.

Thanks Rive.

To the best of my knowledge, the procedure you describe is what I’ve been doing. But to be clear, when you say to set the keypad to “unused”, that’s the same as setting the “keypad used” to “disabled”, right?

I’ve attached a couple of screenshots showing:

  1. CP Q4 settings (with TS1 unused) just prior to exit with save, then re-add/learn
  2. CP screen during Q4 setup (learn screen)
  3. TS1 learn error screen
  4. CP Q4 settings after unsuccessful learn attempt

Although I’m not getting any signal-related messages, I wonder if I need to temporarily put the TS1 in close proximity to the CP (though I don’t remember needing to do that the first time they were paired).

Other hints?

It may be worth checking the transceiver to ensure its still seated properly after the firmware update, by removing it and resetting it. When working on the firmware update, its easy to knock out of alignment.

Couple more photos attached.

Thanks for the suggestion about the transceiver, Amanda. I’ll check that out tonight.

If you are still showing the TS1 (keypad 1) in panel programming then you cannot reinstall/relearn it

Rive,

That screenshot was taken after attempting (but failing) to relearn the panel. There is a different screenshot showing the screen prior to the attempt, in which “used” is “disabled”, etc.

I’m using the procedure shown in Amanda’s video to relearn the panel.

Russ

I’d suggest temporarily bringing the TS1 and Go!Control closer to one another and then attempting the pair. They do not need the same proximity as Zwave devices when learned in, but distance can play a factor. (Oddly enough, directionality as well, as the TS1 transmits best forward through the screen if I recall correctly from an old conversation with 2Gig, but this only typically matters when distance is also a concern.)

Well, I’m stumped.

I tried moving the panels together (10 feet), no good.

I reset the radio module in the CP, no good.

I went through the cycle of removing and learning the TS1 from the CP several times – same thing every time.

I power cycled both units - no change.

I even tried to reflash the TS1, but I wasn’t able to do so (I guess you can’t install the same flash over itself?).

What’s next?

For what it’s worth, my problem seems to be identical to this guy:

I tried again to reflash the TS1, and was able to do so. Unfortunately, this didn’t fix the problem.

The four pin connection is extremely loose, and I had to cock it in the socket to make good contact. I have a feeling that this looseness is what may have caused the problem in the first place.

I don’t suppose you folks at SuretyCam might have a used TS1 laying around that you’d consider parting with, at least temporarily so I can see if a different one works?

The four pin connection is extremely loose, and I had to cock it in the socket to make good contact.

If you put the 4 pin in backwards (so it flopped/layed forward towards top) and did not follow the directions…you may have damaged your TS1.

Source: http://www.2gigforum.com/threads/173-HOWTO-TS1-firmware-update

It may not be the TS1 that is the issue. See this post from October.

Well, regardless if the update FUBARed the TS1 on a fluke, or he fried/damaged it by attaching the update cable/4pin backwards…the end result is the same.

Replacement of the TS1.

No, that is not necessarily what occurred, but you would need to test it. In the prior two cases I am aware of new TS1s did not solve the problem. The problem was occurring in the control panel immediately following a firmware update.

However, the only way to really know that is to try a new TS1 and see if it will pair. Or try the current TS1 on a different control panel.

Yeah, you are right. It was the panel itself in this one at least that had to be replaced:
https://suretyhome.com/forums/topic/failed-firmware-update/

I’m 100% certain that I didn’t put the plug in backwards on the TS1, so that wasn’t it.

Replacing the CP is not on my fun list. Aside from the cost, reprogramming all the sensors will be a real chore.

It sounds like this is an incompatibility between the CP and the firmware. Did you get any response from 2Gig when it happened to the other people?

So I can get the proper info to 2gig, could you provide the model number of the panel? Is it a CNTRL1, CNTRL2, CP21?

In previous post #14894, I posted a screen shot of the panel software, but I don’t see the model number there. I’ll check the panel for that when I get home this evening. Any other information I can provide?

Also, is it possible to transfer the programming data from one panel to another? Some sort of backup and restore?

Model # is located on sticker on panel

Also, is it possible to transfer the programming data from one panel to another? Some sort of backup and restore?

Yes.

You can backup zones from one panel, have it downloaded to another. I have had it done myself. You will have to manually reinstall all TS1/PAD1 keypads, all zwave devices, and redo any console settings, including User codes for other than the Master.