Time setting on GC3

The time on my GC3 panel is off by 45 minutes. I thought the panel is supposed to keep the time updated automatically but it has been like this for weeks now. I’ve tried updating the time manually in settings several times but it hasn’t worked. Please let me know how to fix this. Thanks

That’s an odd interval for it to be off by. I’ve sent a command to set the time based on your location. Allow about 10 minutes to make sure it is complete, then can you confirm if it is correct?

Hi. The panel time is still off. I took this photo at 845pm pacific and the panel shows 936pm.

Ok, I am going to send a reboot to the panel, and one more time-set command. The command sets the time based on your timezone.

If you still have the wrong time in about 15 minutes from now, can you reply with an image of the panel and beside it your phone showing the current accurate time? That way I can show ADC the exact discrepancy.

Thanks. Let me know if this picture is what you need.

Yes, that’s perfect.

Ok, your module responded to a time request sent by ADC earlier with the accurate time for your area. The ADC module has the correct time.

The issue looks like it is with the panel or panel - module communication.

Can you please unplug your panel’s transformer from the outlet it is plugged into, then open the panel and disconnect the battery.

Leave the panel powered off completely for 5 minutes.

Then plug in the battery, close up the panel, and plug in the transformer in its outlet again.

After booting up, allow a couple minutes, any change?

If not, can you try to manually set the time under Settings > Master Code > Date/Time? Does it remain correct after manually setting it?

I was traveling and finally got around to powering down the panel. The time is correct now. Thanks!