Thermostat Schedules Totally Wonky

For the last few weeks at least, I’ve noticed that the schedules I have programmed on the website are completely being ignored by the system. Doesn’t matter what time of day or night it is, the temps are always set incorrectly. I can manually set them, and a few hours later they’re wrong again even though the schedule clearly shows what the various thermostats should be set to.

I’ve removed the smart away controls thinking that might have something to do with it, I’ve edited schedules to try to force an update to be sent, I’ve turned schedules on and off all with the same effect. The temps are always not what the schedule says they should be.

Not sure what to do here.


This sounds like the issue is internal to the thermostat or in how the panel is sending the rule. I would remove, reset, and relearn those thermostats. Does that get them back on the correct values?

There are three thermostats. That will take a while to do and then recreate all the rules again. No other options? How does that happen to all of them at once?

You can try one if preferred and test for a bit on that thermostat, instead of all three. However, considering the steps you state that have already been taken, that would be the next recommended step.

Do you mean remove and re-add or do I need to reset it back to factory settings?

Actually I would recommend one additional step first, update the firmware on the panel. Currently you are on 4.1.1. To get to the latest you would need 4.2.1 first, then you can go to 4.3.0.

Does that help this issue? (I would not expect this alone would fix it, but it is an easier first test)

Then, in the interest of only removing and re-adding once, if firmware alone does not resolve the issue, a factory reset, remove and relearn should be done.

To factory reset:

  1. Put the thermostat into Off mode. When the thermostat is in Off mode, no symbols are lit below the temperature display.
  2. Once in Off mode, press and hold the up arrow on the Smart Thermostat until a version displays. The version number does not matter for this process.
  3. Once the version displays, press and hold the down arrow on the Smart Thermostat until RST displays on the thermostat.
  4. When RST clears from the thermostat display, the thermostat is reset to factory default configurations.

Gotcha. OK, I’ll do the firmware update first and see what happens. Schedules should change once or twice more today still so that will be an easy test. If not then I guess I know what I’m doing tomorrow.

So, I did the two firmware updates up to 4.3.0 and was waiting to see what happened at my next scheduled temp change(s) at 6 PM local.

Lo and behold, 6 PM rolls around I hear the AC come on. Go to the app to check the thermostat settings and all three of them have adjusted to the proper scheduled temps.

Cautiously optimistic at this point. I have other scheduled temp changes for night time, so I’ll be on the look out for what happens then, and again when the house wakes up in the AM.

Fingers crossed I don’t have to do the whole reset and relearn dance. That’s annoying af.

Well, guess I spoke too soon. I checked on the temp settings in the app about an hour after the previously successful scheduled change only to find one of the thermostats was completely out of whack again, set to temps that aren’t part of its normal schedule.


One other thing, all those thermostats are listed as learned in on battery power. If there is a C-wire connected and they are powered via AC, make sure to pair them that way so they do not operate in power saving mode.

After relearning them at the end of the reset process, once all are back in the panel, run a network rediscovery. This should resolve any issues which might cause this behavior.

They’ve said that forever but they are AC powered and I’ve never replaced the AA batteries in them since being installed. They do all report full battery.

I don’t recall but they should have been fully wired to the system before I learned them in the first time.

Is it just a matter of having them connected to power as they are now when re-adding them?

Is it just a matter of having them connected to power as they are now when re-adding them?

Yep. Whether or not they function as a repeating node or operate in power save mode depends only on how they are powered when learned in.

If learned in while on battery only, they will be in power save mode even if AC is applied later. If they are learned in while powered via AC, they will act as repeaters and usually have fewer signaling issues (may not apply here, but still recommended).

Actually I’m 100% certain they were learned in on power because this was done when I replaced the panel a while back. I most definitely didn’t gather them all from around the house into a pile to learn them in but rather ran back and forth up and down just as when I re-added all the sensors etc.

I can tell you that is how they work, all Z-wave thermostats function that way. When paired, they did not have AC power, at least report that way.

After relearning them, let us know and we can verify.

You can also test to make sure they are actually getting AC power now by pulling the batteries and seeing if it still functions. Sometimes C wires are not connected at the HVAC side if the original installer used battery only thermostats.

Originals had no batteries. I still have them in a box.

Anyway, I’ll work on relearning and reprogramming all this stuff. It’s getting hot out this way and having them malfunctioning isn’t acceptable.

Well this keeps getting better. I reset all three thermostats, and then attempted to clear them from the system according to your instructions up there^.

Initially it says “device cleared from the network successfully” and a few seconds later I get “clear operation cancelled.” I didn’t touch anything else, it just happens on its own, and the thermostats are still showing in the device list on the website.

Now what?

Are you following all the steps below? The remove device steps are the first section here:

Do this locally on the panel. Just to rule out everything else, do not trigger Z-wave removal/addition in ADC.

Yes I cleared them from the panel just now (I was trying from the website earlier) but they’re still there on the panel.

I keep getting alerts for malfunctions and that the thermostats are offline, and they’re still in the device list on the panel.

They’ve been reset now too but I can’t clean them out of the devices for some reason.

Something new. I deleted them using the “delete failed device” widget.

Now though one of my Zwave light switches has lost its mind and now reports no neighbor info even after trying to do a network rediscovery. This switch is next to two others that are working on the same wall and two feet from the panel itself. It’s not a signal strength issue.

Ok well deleted that thing and re-added it. Also added back the thermostats. I did a network rediscovery too.

All three thermostats are warning of critical battery levels because…I took them out.

Please tell me that they’re not reporting on battery any longer and I’ll go reprogram everything and my automations etc.