Stuck on Cellular Test

My IQPanel was previously contracted to another company. I’ve disconnected them and purchased a subscription with Surety.

I am stuck on the second step with the cellular test part. It keeps saying no signal found on the other end. Can someone help me?

Looks like this is for an IQ Panel 4, is that right?

If you are having trouble getting the initial cell connection to begin, there are some typical troubleshooting steps that usually help resolve the issue.

First try a reboot of the panel. Settings > Advanced Settings > Reboot Panel. Wait about 5 minutes after boot up, then run another cell test.

If there is no improvement, make sure the system is connected to wifi and update the firmware by the steps linked below. You may need to update incrementally depending on how old your firmware is.

yes its for an IQ Panel 4. Seems to me its working now after a restart. I need to remount it back to the wall bracket to finish the rest of the setup

I can confirm the system is communicating now. Please allow about 20 minutes or so for all initial connection commands to complete. It looks like those are close to done though. Let us know if you have any questions.

Hi Jason,

I think its all completed and I opted in for the doorbell plan. However, when I try to add video camera, it can’t find my door camera. (its green right now)

Can you help?


Troubleshooting steps would depend on the model. What is the model number of the camera you are trying to add?

As an FYI, if it is currently linked to another account it would need to be deleted from that account first.


Model is VDB770. My previous account was deleted entirely. I was able to use the same email address to create a new surety account.

Have you tried entering the MAC address manually on the add video device page in

A factory reset may be needed as a troubleshooting step before trying to link the device to your account.

One last question, how do I view the doorbell camera from my panel? I went here and got a permission denied error

I am able to do so via app


I am not seeing any issue with your account accessing that page. It looks like it should be accessible now. That link is where you go to choose which cameras are accessible on the panel. Can you try again now? If you still see the same thing, try a different browser. Any change?

I am able to see the page now. Is there a way the app can talk to google home.

I tried to look for on google home / said ok google talk to but neither worked

Google Home integration for voice control used to be a feature, but Google cut support for conversational actions which broke the integration and it was dropped. A replacement integration has not been developed.

Voice control is available through Amazon Alexa or Siri custom voice shortcuts