Skybell not displaying in app, records video, sends notifications

I’m having an issue with my Skybell doorbell. It’s been on my account for quite some time, but often see issues with it, so I reset and re-add with some varied name. Recently, when doing this it goes through successful, but I cannot view live video through the app.

Pressing the button notifies my phone, but I can’t watch video, and motion clips aren’t able to be viewed in the app either. Navigating to the app, it shows the camera has been added and configured, but I’m unable to “use” it. When I try, the app says it’s failed to communicate and to retry, which never goes through. I have another video device on same access point and SSID without issue, about 15 feet from one another.

We have had a few similar reports on the Skybell VDB-105 Slim Line, but it looks like you are referring to the HD correct?

I’ve been unable to recreate the issue myself, even with the exact same hardware and software versions. There certainly seems to be an intermittent or rare strange issue or interaction going on with the latest firmware version of the Skybell.

So that we can best assist and troubleshoot, could you let me know what model of router and/or access points the Skybell is connected to?

Also what version of the app are you using?

What model of phone and which carrier?

Do you notice any difference if you are on mobile data only or on wifi only on your phone? (Turn off mobile data for wifi only)

Hi Jason, thanks for your response.

Yes, I have the SkybellHD model.
Also, if I were to go into the app and the config settings, to add another camera, reset this, and perform the install, the same outcome occurs. The configuration states successful, but the app will show no camera configured for an indiscriminate amount of time; eventually it’ll appear.

There are saved video clips from both motion and push-button activation.

I utilize a modem>firewall>switch>access point model, with a Fortigate 30E acting as the firewall/DHCP/router, and Ubiquiti AP Lite’s for Access Points. I believe the Skybell communicates over 443 and as such, have never had specific port forwarding rules enabled since this traffic is allowed natively. Only recently has the issue arisen, with the same network topology and equipment in use. Unless the FW on my Skybell updated without my input, nothing has changed in that aspect.

ADC 4.10.9 on GoogleFi with Pixel 2 running Android 9 (Aug 01, '19 security patch).

With WiFi enabled only, I can view live video.
When WiFi is on with LTE, I cannot, intermittently.
When Wifi is off with LTE, I cannot, intermittently.
I’m testing with the GoogleFi VPN on and off with some success, which I feel may be part of the issue but considering others’ issues, not the root cause.

Firmware does automatically update for ADC cameras in a staggered fashion, including the Skybell doorbells.

New firmware is available upon release to manually download in ADC settings, but it will be automatically downloaded some time later.

With WiFi enabled only, I can view live video.

This is interesting, and another user reported this issue on Google Fi, but has stated this did not fix their issue. A pattern is elusive, but this response helps greatly, thank you!

I’m now very curious if Google Fi’s network switching is at play here.

Do you notice this issue with mobile data on no matter where you are? Have you been able to try from locations other than work or home?

Happy to help, though it’s unfortunate at the expense of my system functioning ideally! lol But, for now I have a workaround.

My Skybell HD FW version is 1154, which is newer than the latest noted on the config page, 1141. I recall about a year or more ago you and the team helping me in excessive motion recordings and pushing that version, any correlation?

I’ve tried from work, but always with WiFi on, and the GoogleFi VPN. I will try over the next few days with/without WiFi/LTE/VPN in varying configs, log my results and report back here.

Thank you, we’ll report all the info to ADC to help with troubleshooting and determine if there is a definitive firmware change that may have caused an issue.

My Skybell HD FW version is 1154, which is newer than the latest noted on the config page, 1141. I recall about a year or more ago you and the team helping me in excessive motion recordings and pushing that version, any correlation?

No correlation, the other device is a Skybell VDB-105 with different firmware (the latest official version).

It may be something on the back-end, but we’ve not been able to reproduce the issue on either an HD or a VDB-105 on multiple phones. I cannot test Google-Fi myself however, so the info here is very helpful in working with ADC!

Looks like this may be the same issue. See this post…

Yes, continued troubleshooting seems to point to the GoogleFi VPN, they must have changed something recently. I posted on Google’s boards as well.

When at work, with both WiFi and LTE on, as well as VPN on, I cannot view live stream of doorbell, however I CAN view live stream of my ADC-V520IR through the app without issue.
While at work with both WiFi and LTE on, but VPN off, the doorbell live stream works immediately without issue. The ADC-V520IR stream continues to work as well.

Obviously what’s odd here is that one video stream doesn’t work through the app, and another does, with the same data stream configuration. It’d be interesting to know if the poster of Roy’s response had tried or has available to try, another video device as I do, to see if their results are similar.

The stream from the Skybell is not the same as the one from ADC cameras, and Skybell servers are involved in the streaming afaik in the Skybell’s case.

I’m waiting on ADC confirmation (they weren’t able to test Fi when I called in, but another rep was going to test and reply) but it appears pretty solidly a Fi VPN issue.