Ports used for IP cameras and Alarm.com

I need to know what port have to be opened for any IP cameras for Alarm.com. I have a few of the older pt cameras and some of the newer pt and outdoor cameras. My network is closed and and standard ports are all forwarded or to the public a few are allowed but tightly controlled.

Currently the cameras show they get an ip but can’t communicate with Alarm.com/Internet and I don’t want to read through the tcp/ip traces for all the ports used.

Thank you,


This one is tricky, because Alarm.com cameras will have been assigned ports during set-up. You could try opening a range as they do group together and start at a specific value.

For a general range, can you open 40900 - 41000 and 41900 - 42000? You can then find the specific port numbers after they have been assigned to the cameras and open those specifically.

EDIT: Also RTSP, 554.

Thanks for the help. I have been able to get some cameras up now and working. I have a ADC-610PT camera with Firmware TC5633-TCAL-0108a working but the second camera does not. I am able to see the camera and it says it is configured correctly but does not show video ever. How can I get assistance with this issue? I have configured all my IP cameras to the same policies to allow communication but this camera does not ever show video.

Please let me know what information is needed to troubleshoot this issue.

Thank you,


I see three devices on the account and all seem to be reporting properly.

Is the camera you are unable to see labeled camera 1 or 2?

I see one connected via wifi and another is reporting hardwired connection.

The camera labeled 1 doesn’t work wired or wireless.


I see it is now removed from the list. Are you re-adding this camera now? There are some test commands I would like to try to help determine if this is a camera fault or settings/network/software issue.

I did remove and read it again. I will leave it as is for now. PTCamera1 is the problem.

That is odd. I am not seeing any network issues at all with available diagnostics. Is this a new camera? Have you definitely opened both the HTTP and HTTPS ports?

Is there somewhere I can show what sensitive information and screenshots to show what I am getting? All my cameras have the same group policy which includes the ability for HTTP/S communication.

Email customerservice@suretyDIY.com

email sent

Do you have a solid green light on the camera?

All cameras when plugged in go through boot up process and end with solid green light. I can click button to turn off led for all cameras and it works even for the one that never shows video.

It looks like, without being able to confirm video, that the camera is functioning the same as the others.

Is this camera new or is it used? Can you verify it functioned previously?

Also, please refresh the live view page and verify whether or not you see video now

I was used by myself for a Vivint account and when I purchased it from them it was new. Both PT cameras worked when I had video service with them.

Did you happen to factory reset the camera when you removed and re-added it previously? That is what I would suggest for a next step if it is still not communicating.

I have done the factory reset for both the PT cameras with the one w/o video having it been done 4x now. I just did the reset earlier today when you saw it removed from account.

What would you need to do to confirm the video?

For security reasons we would not be able to see the video relayed.

Alarm.com is looking into this issue as well.

Does this camera status on the video page show “Failed to connect” after 10-20 seconds of “Connecting?” Or is it stuck on “Connecting”