Playing Video Clips Online


When I log in to to play back Video Clips it will only allow me to play back one clip. After that each Video Clip Window I open will be a blank window. I can move around the web site and then go back to Video Clips and it may play another or I have to log out and log back in to play another clip. Any fix for this?
Also as of this morning, Neither of my cameras will connect on or from the app. Everything is fine on my end.

Thanks, Chris

Can you verify whether or not you can currently access the live view? The cameras are currently reporting their status as ok.

When did the issue regarding only viewing one saved clip then needing to navigate away begin? Which browser and browser version are you using?

Cameras started working just before your post. The video clip issue has been going on since I hooked up my first camera. I thought it was a temporary issue that would go away. Made sure I had the latest java each time before I logged in. Been happening for over a month. I was playing clips back to adjust the motion sensitivity on the outdoor camera. I wanted to see if it actually picked up anything on the camera to better adjust.

Can you tell us which browser and which version of it you are running when looking at the clips? Have you tried a different browser with the same results?

The camera connection issue via web and mobile app are a problem with your network (most likely DHCP). Happens to me periodically.
DHCP determines if your IP is static or dynamic and the length of time an IP address is assigned.

How to fix: unplug camera wall plugs, power cycle/reboot both modem and router. If power cycling, leave off for 30 sec. Once internet is back up, power up cameras.

If cameras still cannot connect, there is a misconfiguration of firewall, and/or router settings.

Download the video clips off, if you still can’t play them its an issue with your PC/PC software.

Can you tell us which browser and which version of it you are running when looking at the clips? Have you tried a different browser with the same results?

I mostly use Google Chrome, running version Version 41.0.2272.35 . I updated to that version to see if it would fix the problem.
I just tried Firefox and it does the same thing.
Internet Explorer is working.

Resetting Cameras and Router had no effect on fixing cameras that were not able to connect on

I checked them online a few times and they were eventually working again.

Chrome no longer supports the plugins required for the website video playback. You have to use IE.

Hmmmmm, That sucks. I hate IE…

I use chrome and IE ( Mostly chrome as my regular use “PC” is a 7" carrier unlocked nexus razor with android KitKat quad core snapdragon S4 Pro CPU @1.5Ghz, 1080p screen res at 1920x1200 via Adreno 320 GPU. I can connect USB thumb drives and a card reader to it, as well as slimport HDMI, have 2GB RAM, 32GB storage, wireless charging, free mobile/cellular data for life, free phone capabilites (free nationwide and Canada), etc). Video settings and configuration I do through IE though on a windows 7 desktop, or a windows 8.1 8" tablet.

I watch vids on the mobile app, and those that I want higher quality for, I download as mp4 from

Thanks for the help, Guess I am forced to use IE for this…

Out of curiosity, are you using IE with Java or ActiveX?

Since I am not a big fan of IE, I chose not to Download the needed ActiveX and opted for Java and it worked fine. Still searching for some type of workaround for Chrome. Everything works fine for me in Chrome except playing consecutive video clips.

Using the latest non-beta version of chrome (40.0.2214.94) and latest Java, I cannot replicate the issues you described. Both live and saved video controls function as expected. Can you revert Chrome to the latest stable version (above) and verify?

Ok, Changed back to the Chrome version you have listed above with the latest version of Java.

Still have the same issue. Let me be a little more clear. When watching video clips, once I open the first clip I can use the arrow on the right to go to the next clip. That will work for the 12 clips on the page. Once you get to the last clip of the 12 and then close the window, you now cannot play video clips. Or if I pic a certain clip to play and then close the window to go to another clip of my choice it will not play anymore clips than the first one.

I can’t seem to reproduce the problem either. I’m using Chrome version 40.0.2214.93 m and Flash Player I’ve tried both methods you described and the video clips still play every time. uses a Java applet (yuck!) for live video but they use Flash Player to play back saved video clips. What version of Flash do you have installed? If you right-click on a video clip while it’s playing back you should see the Flash version number in the context menu.

I am running the same version of Flash. I am getting an error during the opening of the second clip I try to play after closing the first.
When I open the first clip and it starts to play, I right click just outside of the clip but still inside the clip window, then I choose inspect element. It shows me everything that is happening between Chrome and Everything works fine while scrolling through clips using the left and right arrows in the clip window, They all play. If I close the playing clip window and try and open the same clip or a different one, the window opens and does not play the clip. The area where the clip would be is just blank white. If I right click like I did while the first clip was playing and choose inspect element, I now see that I am getting an error when trying to load the clip. Here is the error I am getting:


I get this same error each time I cannot play a clip. It appears that once I play the first clip and close the window, the links to each clip fail to load when opening each subsequent window.

This may seem a bit out of left field, but just to cover all bases, did you have any issues setting up the cameras? Did you factory reset them prior to installation?

I would suggest removing, resetting, and re-adding the cameras into your account. I say this because one of the fields visible to ADC for your camera settings has a value that is off (the cameras do not show as factory reset since last inclusion, perhaps a test account if you bought them new.)

In effect, it is possible an error during registration caused this.

Hi Jason,

Had no problem installing the cameras. I will try resetting them and re-adding them. It may take me a couple days to get back here with the results. Things have gotten very busy for me the last couple of days.

Thanks for your help.

Just checked saved videos online and as of today I can play any clip in any order after closing a video window using Chrome. I do not seem to be getting the error anymore. All links load properly.