No Signal on IQ 2 Panel

I am trying to set up a system that was installed by the prior homeowners. I am on the step to run a cellular test but I’m getting no cellular signal on the IQ 2 panel.

After running the test, I get a message that states cellular radio test timed out. Please try again later. For new installs, please verify an account has been created.

Adding to my prior post, before creating/activating my Surety account, my IQ 2 panel was connected to AT&T. However after I began the process, it no longer is connecting via cellular. I am however connected over WiFi. Here are photos showing the cellular connection before and after.

Please help me enable the cellular connection.

Hmm, looking at the account history, I see a manual phone test, and pings to the system requesting a cell response are successful, except when sending them via cell.

In other words, I can send a ping via broadband and request a cell response, we get an acknowledged response.

Try disabling wifi. Then power down for 20 minutes. (Settings > Advanced Settings > Power Down.)

After 20 minutes, boot up the panel, do not connect wifi again yet, just run a cell test a few times a few minutes after boot up. Any difference in response?

After those steps go ahead and enable wifi again.

Thank you Jason. I followed the steps you outlined and there is still no signal for cellular connection.

Thanks, I am still seeing the panel reporting 0 signal strength in reply to strength checks. It is only accepting commands via broadband.

Can you send a private message with a photo of the inside of the panel with the whole board visible?

Did you factory reset the panel during the setup for any reason?

Thank you again. I sent a private message with a photo of the inside of the panel with the whole board visible.

I have not done a factory reset. I have only tried panel reboots and power downs.