New Cellular module replacement failed


I purchased a new cellular module to replace my existing Verizon 2Gig GC3 module in GC3. Te new module was done using the the cell swap method in the GC3. Once the swap occurred and the new module was inserted I received a Cell network failure ( Radio Not responding error on my GC3 also). I then powered off the GC# by disconnecting the power source and disconnecting the battery. I left the unit off for 10-15 minutes and then powered it back on. It seems that the signal is weak because i had a signal of 1/6. I then performed a swap and put my original unit back into the GC3 and I still get an error for radio Not responding. Everything was working without issue until I swapped my cell radio. My auto arming failed to work last night as it should and the device is connected to wifi, I I don’t understand what has stopped the device from communication as it should. How do I get the Cellular module working again with the new module?

Each account is connected to a single module, registered to the account.

When you physically swap the module, you must also update your account to be registered to the new IMEI number for the new module, otherwise it cannot communicate.

To do so, visit the Surety System Manager here and select the Swap Cellular Module/Panel option. Follow the steps to add your new module and run a cell test.


Thanks that resolved my issue and Iam back online. I dont recall setting that up initially on that page but it works now.

The System Manager has been added in the last few years, giving more account control functions to users. It was not available when you first started.