IQPanel Remote - Patch Verification failed

Hi, I’m trying to upgrade my two IQpanel remotes and they keep failing with the same message. I upgraded the IQpanel 2 to version 2.7.0 with patch tag. Then when the remote panels try to upgrade, they keep failing. I’ve tried rebooting, rediscover, reconnect, and test. The devices pair to the main panel and are receiving valid IPs on my LAN. They just keep failing after downloading patch to 100%.

What should I try next?

Can you try the same with the panels connected directly to the IQ Panel Access Point?

See access point settings on page 87 in the manual here.

The panels are now connected to the IQ panel access point, but its the same result of patch verification failed. I connected the remotes by IP to main panel when doing a reconnect and it finds panel to start patch download again. Gets to 100% and then shows same error.

1 Like

You mentioned rebooting, was that the Remotes or the IQ Panel itself? I would reboot the IQ Panel, reboot the router, then once the IQ Remotes reconnect try again.

What firmware version are the IQ Remotes on right now? What version did you upgrade from?

My reboots have been on the remotes. I have rebooted the Panel recently and no change.

I went from 2.5.3 I believe to 2…7.0. The remotes had no issue going to 2.5.3, but when i went to 2.7.0 on the main panel, the issues started. How can i tell the version on the remotes?

The remotes show 2.5.2rc2

The remotes show 2.5.2rc2

That is the issue I think. That strikes me as a non-production firmware version identifier. Looks like those got incorrect firmware through the panel. Let me reach out to Qolsys and have them confirm and see what steps to resolve.

1 Like

Still waiting on follow up from Qolsys. At this point we will not hear back from them until after the holiday. We will follow up as soon as we have more information.

1 Like

Have you heard anything back yet?

Not yet, I have reached out to them to see if we cant get some more information today.

1 Like

My reboots have been on the remotes. I have rebooted the Panel recently and no change.

Have you performed a Master Reset of the IQ Remote? If not, to do so, click on the 3 vertical dots in the upper right hand corner of the IQ Remote main screen and select Master Reset. This will factory default the IQ Remote, and you can retry connection.

1 Like


I have tried this and it does the same thing trying to pull an update. I’ve connected the remotes to my SSID and the IQPanel AP. They pair, sync with panel, download the patch, and fail at verification. It’s the same error message.

Thank you for that information. Im working with Qolsys to get this resolved, what are the Serial Numbers for the two remotes affected?

These numbers can be found on the back of the unit and begin with QWXXXXXXX

I’m having the same issue on my IQRemote panel in our bedroom. I’ve rebooted, reconnected, rediscovered, tested, master reset, rebooted both panels, verified connection on the same network (they see each other and talk to each other successfully).

It breaks at the point when it’s downloading the update, then “patch verification failed”. I can’t get out of the main wifi/configuration screen. It’s non-functional.

It would have been handy last night during our Tornado Warning in Kansas City, which is why I’m posting for support. I need to find a solution quickly, I’ve let it sit unfunctional for too long.

What is the firmware version the remote currently shows?

The current firmware on the remote shows as 2.5.4rc19. I just upgraded the panel to 2.7.0rc to see if it would fix it, but it did not. Same behavior, downloads the patch immediately after establishing connection with the main panel, then the message patch verification failed.

Forgot to mention, I totally deleted the remote panels and re-added them to the main panel, still same issue.

I downloaded the 2.7.0rc firmware to an SD card, but it looks like there is no SD card slot on the IQRemote panel to do a manual upgrade from the card. A bit stuck at this point.

I remember an issue a while back that required increasing log level.

I haven’t tried this yet, but I would only be able to modify on the main panel. The remote panel doesn’t have access to the settings, it’s stuck on the wifi and test/reconnect screen.

[Removed by Admin}

To clarify, you updated the main panel to firmware version 2.7.0 already? Can you confirm by navigating to Settings > Advanced Settings > About > Software > Software Version

Thank you for that information, I will follow up shortly.

1 Like