iq2 will not connect (pair) with iq main panel

Hoping someone here has an answer for this problem.

My iQ main panel works flawlessly and it receives an excellent wifi signal. No problems whatsoever. Upon receiving iQ2, I followed all included directions and checked that:

both were on same network and receiving an excellent signal
both have the most updated software: main panel (1.4.3) and iQ2 (1.4)
went to “security account” and checked the box to enable iQ2

Then I went to “remote devices” (which is named “iQ2 devices” in new software version), pressed “add new” and entered iQ2 for name and entered the ip address.

Now here is where the problem is… after pressing “save” i very briefly receive the message " please wait…adding iQ2 device" then it goes to this message for 10 seconds… “Operation timed out…retrying now”. After this it goes back to the “iQ2 devices screen” with nothing listed and at the bottom a window briefly says “failed…unable to connect iQ2”.

I tried following the items in the numerical step order on the enclosed “Troubleshooting” section:

  1. Both connected to same wifi network
  2. Unable to use “ping” in "remote devices (iQ2 devices) because I don’t get a “ping” option in that window.
    3.tried resetting iQ2. I guess this reset, however my network was still connected so I really can’t verify what it actually “resets”
    4.Could not delete iQ2 from the iQ panel because it never paired with it to begin with and is not listed.

I also tried doing an iQ2 devices test, but again it is not listed, it didn’t pair. And i powered down the iQ2 and restarted it.

Next, I called Qolsys and the tech walked me through rebooting my main panel, made sure that software on both was up to date, (it is) and mentioned something about verifying my router being 2.4 (which it is, cause its working with the main panel. He said if it was a 5.GHz router, it would not work with the iQ2 ) Tech also had me “forget” wifi settings on iQ2 and re-enter password for network. He could not help me after that.

So here is what I have now…a very fancy beautiful display of todays time and date!!!

At least most of you out there were able to connect with the main panel…I can’t.(poor me!)

I poured myself a martini…well THAT works!!!

Any one out there have any ideas? Thank you!

Well, barring a typo in the IP address, have you tried Settings - Installer Code - Panel Reboot? (on the main IQ panel) Then try to perform the same steps?

Yes sir, I did. The tech at Qolsys stayed on the phone while my main panel rebooted, and it did same thing. Then he said he couldn’t help me. And to your other question, I typed in the IP address exactly as it was shown on the “about” screen of the iQ2. Thank you for your response.

You could always verify your router is seeing the IQ2 as a connected device. Could you check your router status or connected devices list to see if the IQ2 IP shows up as currently connected?

And to avoid some silly unknown naming limitation, can you try selecting a different name than “IQ2?”

Try “Keypad” or “Bedroom Panel”

What type of wireless encryption are you using? Have you tried a different setting?

I did try renaming it other than iQ2…no luck. Even “iQ remote” as they do. I wish it was this though!!

As for your other suggestions, you are getting a bit too advanced for me. I don’t know how to check my router status/connected devices list. My internet provider, Optimum, states that the ability to check my router status/connected devices is not available in my area, but will be soon. My router is a Surfboard SBV5120.

Using WPA2

A ?..If my main panel has no problem with my router or settings, why should iQ2 be any different? Thanks again for your help

It really shouldn’t make a difference, but we are looking at either a strange unknown issue, or just a bad piece of hardware/corrupted firmware. I’m struggling to find anything that was overlooked.

How did you “Reset” the IQ2? Did you use the “Reset Data” option in the More menu?

Yes I went to the more menu, then hit reset. A window appears asking " Do You want to clear data?" I hit yes, but it doesn’t seem like it really clears anything. What i mean is, the button doesn’t “highlight” at all like the “more” button does when you press it.

The Qolsys tech had me "reset"it this way, but also went to wifi setting and my network was still connected. I thought a “reset” should wipe that clean and start anew, but he could not answer that one. His answer was to go to the “forget” button in wifi and reconnect.

Any other way to reset this?

I do not know of one myself, but I have taken this to Qolsys Engineers to see if they have a suggestion. In case it is relevant based on their response, can you provide the Revision of the IQ panel?

Thank you very much for your time and interest in this matter.

Panel indicates:

software version:
Q 1.4.3-ADCS 4.2-ADCL 4.2

I mean the physical Revision. It will be labeled on the panel as Rev(letter), like RevA, RevD, etc.

We need to check if this was a factory V 1.4 firmware as well. If it is, it will wake up upon touching the screen. Can you turn off the screen from the side and then see if the IQ2 screen will come back on by touching the screen?

Yes it has 1.4 listed in iQ2 and it does wake up when touching screen

Rev F

Thank you

Also, i went through my Airport Utility, and it is being acknowledged by my router.

Well Jason I just received my new iq2 because I too thought it was maybe bad firmware or the unit itself, and this one does the same thing! I’m done. This should be a piece of cake. Thanks for your time!!

Well, on the positive side, that narrows down the issue a bit. It definitely helps point Qolsys where to look for issues.

The router is possibly causing the problem. Or it could be the control panel itself.

I have had difficulty with Apple routers with regard to alarm products in the past (mostly cameras). They do not seem to play as well with IOT devices. However, with no direct experience with an Apple Airport and an IQ2, I cannot say for certain whether this would pose an issue. I have updated Qolsys regarding this.

Ok. Thank you.
FYI & Qolsys:
I do have a new airport extreme (part # ME918LL/A) and it is a dual band 802.11ac.Product description of airport extreme says it transmits in both bands and the device seeks the best available band. Just puzzling how the main iq panel works with no problem, and this doesn’t.

Have you checked the firmware version on your router? Its possible it needs an update. I had a similar issue a few months back and it self corrected. I have no idea how, but its possible that my router got a firmware update that allowed it to add the IQ2…

I have the latest firmware on the router installed. Still same problem. Thank you.

Try manually configuring the network device. Don’t use auto settings, since it is dual band you will have two separate bands- 2.4 and 5ghz. Do not use the same SSID or passcode for both bands. Set the 2.4ghz band to the best available channel, do not use overlaps. Use 1, 6, or 11 (use channel with least congestion you can use an app on smartphone to see channels), use a wide channel (e.g., 40mhz), use AES WPA2 encryption.

Also try mixed wireless network mode on the 2.4ghz band. Be sure to connect the main Qolsys and IQ2 secondary panels to the newly created SSID.

Manually enter passcode, and connect to that 2.4ghz SSID you created. Be aware also that the router firewall will block certain ports that may be needed, so set it to low (unless you know how to configure the firewall and open necessary ports).

It is possible your IQ2s are connecting to the 5ghz Network. The IQ will connect only to 2.4.

Can you check to see if the IQ2 is on the 5G network? If so you may be able to filter it using the MAC. Or you can try just changing the SSID of the 5G.