How to enable video time stamp data

Good morning

Somehow the video timestamp data on live video from two of my cameras, “front porch” and “front yard” is gone. I have searched all through the settings and cannot figure out how to enable it. Is this something I should be able to do on my end or does it have to come from you?


The time stamp cannot be disabled or have its format changed as far as I know. So it is interesting that it is not appear on those two specifically.

Does this issue show on the camera labeled Lower Level as well? I ask bc this camera is the same make as the Front Porch and they share the same firmware.

When did this begin?

Have you power cycled the cameras?


The time stamp is showing on the “lower level” camera.

The issue started yesterday. I was having issues w my internet and had to factory reset the router so I did power cycle the camera a few times I think.

Other than the timestamp, the camera is working correctly? Recording rules are triggering and live view is current?

Rebooting the camera should resolve the issue. Ive reached out to ADC to see if this is a known issue but its not something that we have specifically come across afaik

@tyler The camera are functioning correctly in all the areas you mentioned. I will reboot the cameras soon when I get home and report back.

Is the issue appearing on the app, or website, or both?

If using website, what browser? Have you tried a different browsers?


The timestamp does not appear in the app or Safari browser on my MacBook. I just restarted the effective cameras with the same result.

  • Are you able to test via a different browswer?
  • Have you logged out of ADC, then back in?

I just tried Chrome-same result.

I logged out of app and back in-same result.

As a test, I would delete one of the cameras that is exhibiting ths behavior from Then factory reset the camera and re-add it to

Cameras are deleted from the ADC website via Video >Settings > Video Device Infro > Select the camera from the drop down then click on the Delete Icon in Video Device Info.

Factory Reset instructions vary from camera to camera complete steps can be found in the manual but most steps can be found here After factory resetting the camera leave it alone for a couple minutes before re-pairing.

I just observed that the time stamps disappeared from all 4 of my cams. 2 of them on 5/25 at about 2pm PDT, and the other 2 on 5/26 at about 8:00am PDT.

I’m thinking it’s not an app problem because I see the same thing on both Android and IOS. I have 4 ADC-VC826 cams and an ADC-SVR122 with a 1T hard drive.

@calkids @tyler

Interesting. Maybe we have a ADC issue here.

Also @tyler , I did not have time to delete and reinstall the camera to see if that corrects the issue. I will try later today after work.

I reached out to ADC reps yesterday who had not encountered the issue.

Removing/Re-adding the camera may resolve.

The only time ive ever seen the time stamp be removed is when you zoom in on the live view screen (ex. from the website you can use the mouse scroll function to zoom in on the image) doing so makes the time stamp disappear but this is only temporary, re-loading or zooming out has the time stamp return.

Weird that another user is reporting the same issue and it’s not isolated to me. Also, I experience it on two different models of cameras. Strange. I will delete and re install later and report back.

FWIW, timestamps have returned on all 4 of my ADC-VC826 cams. The recorded times that the timestamps turned off and turned back on are (PDT):

  • CAM1 - OFF 05/25/22 01:57 PM ON 05/27/22 10:17 AM (off for 44 hr 20 min)
  • CAM2 - OFF 05/25/22 01:57 PM ON 05/27/22 10:18 AM (off for 44 hr 21 min)
  • CAM3 - OFF 05/26/22 08:09 AM ON 05/27/22 06:21 PM (off for 34 hr 12 min)
  • CAM4 - OFF 05/26/22 08:12 AM ON 05/27/22 02:22 AM (off for 18 hr 10 min)

The firmware on all cameras is V5.5.82.210706.

All cameras have been powered the entire time, as has the POE switch and router.

Any thoughts what caused the timestamps to disappear then reappear?

I can’t corroborate the same behavior here yet, but it may be an ADC back-end issue that was resolved. I’ll take a look at some test cams to see if we saw similar activity.


I haven’t had the chance to delete and re install yet but I am still experiencing the issue.

I may have discovered a (the?) reason why the timestamps disappeared. This evening I changed the Video Device Image Settings on CAM1 at 6:14 pm and on CAM3 at 6:15 pm. When the cams restarted the timestamps were turned off for both recordings and live stream. I’ll check the SVR tomorrow to determine when (if?) they turn on again.

Follow up to my message last evening regarding cam timestamps disappearing after changing the Video Device Image Settings:

CAM1 off 6/1 at 6:14 pm | on 6/2 at 2:57 am (off for 8 hr 43 min)
CAM3 off 6/1 at 6:15 pm | on 6/2 at 3:14 am (off for 8 hr 59 min)