Firmware update

I am trying to update firmware on my 2Gig control panel. Current version is 1.6. I have followed the tutorial video and pdf instructions and can’t seem to get it to work. I have downloaded the zip file from the link above the video and connected the cable. After I create a shortcut and edit the target, nothing happens when I double click the file. What am I doing wrong?


does a dialog box open or not?

No dialog box opens. That’s where I’m stuck.

I posted a video above, If you don’t get the “No Panel” dialog box, then the driver/software isn’t properly installed. Reinstall, or try another PC.

I had this happen to me a couple times. A reinstall of Windows usually resolved it, I never had much luck troubleshooting the actual cause.

When I run CDM20814 Setup, it says drivers successfully installed. Any ideas where it might be going wrong?

As I said, It happened to me twice. I was never able to fix it, until I restored windows

I’ll give that a shot. Thanks

Were you able to run the update?

I have tried two different PCs and reinstalled windows on one of them. Still the same problem. No dialog box opens. I’m out of ideas.

I would recommend using a Windows 7 or 8 machine if you can’t get it to work on 10. That said, I have used a windows 10 laptop myself to run updates. UAC is a bit more of a bulldog in Windows 10, and may be contributing.

Have you tried right clicking the link and choosing to “Run as Administrator”?

Also note, even with cable unplugged, running the shortcut should bring up the software window, showing “Fail” rather than “No Panel”

Opening your task manager can help verify whether the program ever starts. The easiest troubleshooting step would be to attempt to run as administrator, as this is a common error in general.

Running as Admin is NOT necessary.

I just (like now) installed it in on Win10 (up to date, latest build), see:

I’ve been able to get the dialog box to open on windows 8.1. Having to install an older version OS on my computer is not ideal, but it’s all I have been able to get to work. The problem I’m having now is no flashing. The dialog box just stays on no panel and pinging. Any advice?

A few restarts of everything and it’s flashing now. I’m still looking for a solution to the Windows 10 problems. Hopefully when I reload window 10 this time it will work.

The update finished successfully, sort of. Everything looked just like the videos that I’ve watched. However, now the control panel will not turn on. Any suggestions?

Did you flash the correct firmware? If the panel will not power up, then you will probably have to replace it.

Be sure to check the wiring connections on both the plug in power supply and the terminal block in the panel. Check for a broken or loose wire. Depending on how much the panel has been moved around, the gauge of the cable, and whether you are using solid or stranded cable, it may be possible a conductor snapped.

Also note the panel will not power up from battery alone, it will only power up once the plug in power supply is applied.

I flashed 1.14 twice just to make sure it was correct. The power supply wiring is good. It was working up until I finally got the firmware update to work. I left it plugged in overnight to make sure the battery is charged.


Did you happen to remove the transceiver when applying the update? If the transceiver was moved, check to make sure it was reinstalled correctly with the pin terminals.

Are you able to test power at the panel terminal block with a multimeter?

Was the cable secured while the update was running?

Just to be sure, you actually mean the CP1, and not the TS1, correct?

When you flashed the CP1 the second time, did you wait until the small OTA update finished, and panel rebooted first? Or did you power it down/reflash in the midst of the update?

For the firmware to successfully complete, you would have seen a green “PASS” screen. At that point the panel has already rebooted, and you will hear it announce “ready to arm”, and the firmware program has already done its delay after flash (prior to pass screen). Then you disconnect power, and when powered down, remove the J4 end of the USB cable.

Then you power back up.

Did this occur, all except for the last power up?