Firmware update

Hi, got my cable to update the firmware on my 2gig system. Just wanted to make sure that you guys don’t know of any new updates coming out in the next few weeks… If so I’ll just wait until then to update it so I don’t have to do it twice.

Also, there haven’t been any firmware updates for the Yale deadbolts, have there? (If they’re even updatable)


I would expect a new 2GIG firmware out by early April. They usually like to have something new to show at ISC West. I haven’t been given any hard release dates though. I’m not aware of any Yale updates, are you having a Yale issue you’re hoping an update will fix?

Hey Ryan,
I had e-mailed someone a few months ago (I think Amanda?) because one of my Yale locks keeps losing all the access codes I program online. It still disarms the alarm and unlocks with the master programming code, and I can still control it remotely from the ADC app and query its status from the 2gig panel, but when I reprogram the codes (via ADC website by first unselecting all the saved user codes, then saving, then reselecting and saving again) it only keeps them for anywhere from a few minutes to maybe a week max. I have another Yale lock that is unaffected and keeps all the user codes exactly as its supposed to…

Amanda said that 2gig firmware 1.10.1 addressed some known lock issues (although she did say she hadn’t heard of it addressing anything like this with the Yale lock), so I bought the firmware cable and flashed everything last night. Figured it was worth a try. As of today all the user codes stopped working on the lock again.

Do I just have a defective Yale lock? Is there something else I’m missing?


Yep, now I remember discussing that issue. That’s disappointing. The 2GIG 1.10.1 firmware release notes say

• Support for the 2GIG GC3GAT 3G cell radio and associated Telguard remote services.
• A fix for the scenario where Z Wave lock codes were being removed after system configuration change.
• Minor Spanish language corrections.

so I was hoping that would do the trick. I was just looking at the status of your locks and I see the front door is reporting malfunction. Do you happen to be working on it now which could cause it to report malfunction or is the lock actually malfunctioning on it’s own? Is the front door the one you’re having trouble with?

A few things that might worth trying are

  1. Make sure the lock isn’t in lock out mode. See attached.

  2. Make sure the lock isn’t in privacy mode. See attached.

  1. On one occasion I remember a customer’s Yale locks were not taking the lock codes. Removing them from the z-network and re-adding them again fixed the problem. Yours is a slightly different problem where they’re taking the codes initially and then forgetting them later but it’s worth a shot.

Can you provide any specific time when you noticed it happened? It would really help if we could look in the event history to determine whether is telling the locks to delete those users codes or if the locks are deleting them on their own.



Hey Ryan,
Thanks for the quick reply. Sorry for the delay - super busy at the moment.

re: the front door malfunction - that wasn’t my doing - started doing it spontaneously. The locks have actually been acting up in different ways since the 1.10.1 update:
-I won’t be able to unlock it manually from the inside, then I’ll apply some pressure, hear a little grind of going against the motor, and then it will go (so it’s getting jammed I guess). This is on both locks
-The front door did that malfunction thing
-The kitchen door lock (haven’t tried with the front door lock) now will still open with the master code (I reprogrammed it with the other codes, and they worked for like 48 hours but stopped working sometime before this evening), but it no longer disarms the alarm.

I’ll try deleting and readding them to the network (is this easiest from the locks themselves or from the 2gig panel?). Should I do any kind of hard reset on the locks or anything? This is driving me nuts

Thanks for the help!

One thing to keep in mind is that the 1.10.1 update is a 2GIG firmware update, it doesn’t update anything on the locks themselves. If you’re having trouble using the lock directly (not just through z-wave) then the firmware update wouldn’t have anything to do with that.

The deadbolt needs to be able to easily slide back and forth when you lock/unlock it using the thumb turn on the inside. If you have to turn it any harder than you would when the door is wide open then you have a problem. There are 2 things I’ve seen cause this.

  1. The door isn’t aligned well with the deadbolt strike when the door is closed. If you have to push or pull the door at all to lock and unlock the deadbolt then it’s not aligned well. You should be able to easily turn the thumb turn and slide the bolt back and forth when the door is closed without having to touch or move the door at all.

The solution to this is to move/adjust the strike plate (on the door frame) for the door handle/latch so that when the door is closed the deadbolt is aligned well with the deadbolt strike plate. There are 2 strike plates in the door frame - 1 for the door handle/latch and the other for the deadbolt. Moving the strike plate for the door handle/latch will adjust how the door is aligned in the frame when the door is closed and therefore how the deadbolt is aligned with the deadbolt strike plate.

  1. The screws holding the deadbolt on the door are tightened too tight. If they’re too tight that causes the lock itself to squeeze around the bolt and prevents the bolt from sliding easily.

The solution to this is to just loosen the screws you used to mount the lock onto the door.

It sounds like (1) is your problem since you said you can unlock it when you put some pressure on the door. If the motor is having trouble moving the bolt because of one of these issues then it will report a malfunction to

If you did remove the lock from the z-wave network and then re-add it, the user code access settings and emPower rules on have to be reprogrammed. thinks it’s a whole new lock.

Yale does provide end user technical support so if you’re having physical lock installation problems try calling then at the number below. They’ll want you to work with us on the z-wave issues but they’ll help with the physical installation.

1-800-810-WIRE (9473) Support is available 8:00 a.m. - 5:00 p.m. EST

Hey Ryan,
Thanks again for all the help. I did a poor job of describing that one problem - it wasn’t anything to do with the door frame. The part that jammed was the part you turn on the inside of the lock to lock/unlock it. It didn’t jam as a result of the deadbolt alignment, it jammed because of something weird with the motor in the lock… if you gave it a little more pressure you felt resistance from the motor give out and then it would turn normally.

Fortunately, that hasn’t happened again on either lock.

I’m still having a problem (this one since the update), but I think I narrowed it down:
The locks aren’t sending data to the 2gig control panel.
-Entering a code to unlock the lock stopped unlocking the panel
-I can still unlock the locks remotely from the ADC iPhone app
-The locks aren’t taking any new codes from the ADC site

I think I just need to remove and re-add the locks to the z-wave network, but it won’t let me… the following happens:
-If I go through the menus on the lock and select “remove from wireless network”, it just makes the error noise and flashes all the numbers like I entered an incorrect code
-On the 2gig panel, if I go to z-wave > advanced > all devices > select either lock - it waits like 60 seconds and then flashes some error about the panel not receiving data from the lock
-On the 2gig panel, if I go to z-wave > remove devices it just gives me a blank screen for about 60 seconds and then returns to the home screen (I assume it times out)

Any idea how to just remove the locks from the z-wave network so I can re-add them? Things are way worse than before since now the locks can’t disarm the panel

BTW - thanks for the AMAZING customer support. I’ve recommended you guys to a ton of friends. Sorry this issue is so annoying.

The problem with the thumb turn getting slightly stuck when you try to turn it is usually caused by the screws that mount the lock onto the door being screwed too tight. I’ve seen that happen quite a few times but I haven’t yet seen one where the motor was causing the resistance. If you’re still feeling any resistance on the thumb turn I would loosen those internal screws and see if it helps. Although lock mounting issues and/or motor issues are probably better handled by calling Yale’s tech support directly. They’re better locksmiths than we are.

1-800-810-WIRE (9473) Support is available 8:00 a.m. – 5:00 p.m. EST

As for the z-wave problem, how far are the locks from the 2GIG panel? It might be just a simple communication issue. The locks themselves are battery powered and therefore they go to sleep and they don’t transmit as powerfully as wall powered devices. Additionally, because of the heavy encryption used in lock communication, the z-wave messages from locks are much larger than z-wave messages from most other devices so it’s more likely that they get interfered with or interrupted before being received properly. A good rule of thumb is that if you have a door lock more than 25ft from the 2GIG panel with line of sight then you should also install an light/appliance module or a repeater (or any wall powered z-wave device that supports the z-wave beam command) within 25ft of the lock, even within 15ft if possible. That way the more powerful wall powered node will receive and repeat the weaker signal from/to the lock.

I see that you do have a lot of z-wave lights already but I also see that they’re made by GE/Jasco. Older Jasco z-wave lights did not support the z-wave beam command and therefore were not able to wake up a sleeping lock when repeating messages. I think there was a way to tell whether your Jasco modules are new enough to support the beam command but I can’t remember what it is. I’ll do some digging and let you know.

This post might help for removing/adding the lock to the 2GIG z-wave network.

Don’t forget to do a rediscover network after every time you add/remove/change the z-wave network.

Hey Ryan,
So that Kitchen Door lock was working fine prior to the firmware update, and I know that they’re the newest Jasco lights, so it’s definitely not a range issue.

I called Yale today and they pointed out that on the lock that works, the Z-wave module has firmware v2.0, while the Kitchen Lock has v1.8. They’re sending me a new z-wave module with v2.0 (which I assume will also make the lock into a completely new z-wave device as far as the 2gig panel is concerned), so hopefully that’ll solve the problem. I’ll keep you posted. Thanks for all your help!

Hey Ryan,
So good news - with 2gig firmware 1.10.1 and the new Yale z-wave module with firmware v2.0 the lock is successfully responding to queries from the panel, programming user codes from the ADC portal, and not forgetting the codes after two days.

The only problem now is that the user codes entered on the lock won’t disarm the alarm system. If I use my code to open the lock, the ADC history will say “Lock unlocked by Mark”, so it’s definitely communicating, but the panel won’t disarm automatically. I have to enter the same code into the panel to turn off the alarm.

Sorry for being such a pain - just trying to get this all sorted out. Any thoughts? It seems like this problem is on the 2gig side of things now

It doesn’t look like you’re doing anything wrong. We’ve been dealing with an automation problem between 2GIG and for months now. It seems to be more likely to occur when there are a lot of automation rules on the account. I have a theory that the problem has to do with the 2GIG panel getting out of sync with the back-end when multiple rules are being edited/saved around the same time. It’s been a tough problem to reproduce but there are people working on it at now. We’re anxiously awaiting a resolution.

You may be able to work around the problem by deleting the rule that disarms when the door is unlocked, waiting a few minutes and then creating a new rule in it’s place that does the same thing. If that doesn’t work, let us know and we’ll try clearing and resending your automation rules from the back end.

That last part was my fault - didn’t make a new rule to disarm the alarm when the lock was unlocked (it was effectively a new device because of the new z-wave module in the lock).

Just wanted to thank you for all your help. Everything is finally working perfectly! The answers seems to be a combination of 2gig firmware 1.10.1 and the Yale Z-wave module firmware 2.0.

Thanks again for everything - your support is stellar. I’ll definitely be sticking around for years to come (and upgrading my panel to the 2gig 3.0 system when it’s available)!

Thank you too! That’s good information to know about Yale firmware version 1.8 and hopefully others with the same problem will find your post.

When did 1.14 come out for the 2gig panel?

1.14 is a future release. It is not out yet.

It has not been released. While we hope to see it soon, there is no ETA at this time. Firmware V1.13 is the latest firmware for the 2GIG Go!Control panel right now.


Yep, the DW40 is available now, but you cannot access the local bypass logging until 1.14 is released.

I currently have Vivint (yes I know) I am only about 18 months into a 42 month contract so I am not quite ready to do a takeover yet. Q44/45 are all set and I have programming access. I am running the Vivint 1.9.6 firmware. I want to add things like linear garage door opener, etc. I was wondering if my system will still work with Vivint if I flash firmware to v 1.13. Any help would be most appreciated.

It should not have a negative impact on the back end if it is being used. However, we unfortunately cannot comment on the policies of another dealer, and you will want to consult whether or not there are any resulting undesirable effects if an upgrade is performed.