Cellular module communication issues

Received alerts saying the panel is not responding. I’m not sure what may have caused this. I was likely changing configuration and adding some sensors at that time but as far as I can tell nothing should have stopped cell communication. The radio status signal shows 31/31 but the button is orange. The most troubling thing and a likely source of the problem is that the radio serial now shows 123456789012345 and subscriber ID is 1234567890123456789. Connection status is “idle (No OTASP)”. If I try a cell phone test, the display just remains blank and seemingly locks up the panel. I hope you can help sort this out. Thanks!

That’s not an issue I am aware of (regarding the serial number misreport).

Have you attempted a full power cycle of the panel? I would suggest trying that first to see if we can kick start connection. Power down, transformer plug first, then battery, wait fifteen seconds, then power up, battery first then transformer.

Once the panel boots back up, wait a minute then run a cell test.

Yes, I have power cycled it twice last night with no success. The second time I also removed and re-seated the cell module but that didn’t help either. The cell phone test doesn’t seem to respond at all. No text shows up on the display regarding success/fail status.

Other than a 2Gig hardware fault, this could be a carrier level issue. I have spoken to ADC regarding this and they are looking into the issue. Can you confirm your panel is still showing an improper serial number for the radio? Was it showing this way the entire time you have noticed the issue?

Post screenshot…like this

It was still showing the incorrect serial this morning, but I can verify again when I get home for lunch in about an hour. It was only last night that I noticed the communication alerts and tried to get it corrected, which is when I noticed the serial number being generic. It had not been that way before but I had not checked it recently.

I’ll take some pictures as well. I can say though that the Cell Phone Test screen as pictured above just has the two blue text boxes, with no text at all. How long should this process take typically? I let it sit for several minutes last night and it was blank the whole time and I had no way to cancel it other than power cycle it.

If it were a carrier level fault (as shown in above posted images), then cell test would just fail…the fact that the cell module info is not being read or displayed on screen, suggests a hardware issue.

Sounds like you have one of two issues:

  1. Defective cell module
  2. Defective panel

I doubt its fixable, so you are looking at either obtaining a new cell module or a new panel

My understanding is that both have at least a 1 yr manufacturer warranty in any event

In speaking with 2Gig, they say that this is one of two scenarios where it is clearly a failed or damaged module. The key here is the 31/31 and the serial number registering 1234567890…etc. This indicates the module is no longer responding to the panel. The second scenario is where Radio status disappears or never shows up to begin with.

The modules carry a 1-year warranty. When was this module purchased?

It was well over a year ago. The module came with the panel I purchased on ebay for a great price. It has worked perfectly until now so I can’t complain. It’s too bad modules can be locked in to certain providers. I have an old APX branded panel that came with the house, but I of course just replaced that with the panel I brought with me. Has anyone ever had any success getting Vivint to unlock their cell modules?

I guess I may as well take this as a sign that I’m meant to have one of these new GoBridge devices. Are you able to share your pricing on them yet? Luckily I already have the firmware cable, so I can get that updated.

The GoBridge should be made available this weekend on our online store, I do not have pricing info available.

Please note however, that the GoBridge does not and cannot replace a cellular module as your primary means of communication with Alarm.com. Alarm.com requires use of the cell module.

The GoBridge is a concurrent back-up and means of faster inbound commands.

Vivint will never unlock/release their cell modules. All 3G Vivint modules end with -“V” instead of -“A”, and 2G modules are GSM1, GSM3, GSM5 GSM7

If you have a Vivint panel, you can check the cell module with it.

Update Vivint panel firmware with USB cable to current version (if it is not v1.9.6)

Have suretycam perform an ADC backup for all zones, then…

Put the module and antenna in the Vivint panel, power it up and perform a cell test. If it suceeds, that means your other panel is bad. You can have the Vivint panel unlocked by having suretycam remotely reset Q44 to 0 via airfx (installer code for Vivint panel is 2203)

Fully enable and optimize Vivint panel:

If the Vivint panel can’t see the cell module, then you will be certain the cell module is bad, and just replace it. Then if you want, still unlock the Vivint panel, and sell it on ebay if you so desire…a used optimized/unlocked Vivint panel running firmware 1.12 will go for approx $50 on eBay.

Interesting. So, I couldn’t connect the GoBridge and have a working Alarm.com / CS reporting until I also get a new cell module? If that’s the case, it seems the concurrent Internet backup isn’t a backup at all. I certainly intended to have both, but if having the GoBridge wouldn’t keep me connected in this event, where the cell module has died, I guess I don’t see the point in having one right now. I suppose when I can get around to adding more Zwave features and upgrade from the Basic package, the faster commands would be beneficial.

Thanks for the clarification!

As far as I understand the policy (I haven’t had a chance to lay my hands on the GoBridge yet to give definitive instructions) it’s just that you can’t have IP ONLY communication, so it also requires that customers use the cellular connection. It IS backup in the sense that if cell communications fail, the signals would still be transmitted via IP (and vice-versa) because both transmit simultaneously.

You just can’t set up or downgrade an account so that all you use is IP. It cannot be the sole primary communication method.

It may be that there are setup steps for the GoBridge which require the cell connection to be active, but I do not know that for sure as of today and will have to verify that and update the thread.

Well, it’s not the cell module! I upgraded the firmware on the APX/Vivint panel and installed it in there and it’s connecting fine. ADC just notified me communication was restored. Bummer though, since I guess it’s my main panel that has a problem. All other functions seem to be working though. Do you suppose a factory reset may have any effect? Won’t be fun reprogramming my 30 zones again, but looks like I’ll be doing that anyway if I have to end up using this APX one.

Wow, now that’s interesting. Thanks for posting. Going to have to chat with 2Gig.

The last backup for your panel should be available if you would like that pushed through. Please live-chat in if you would like to attempt a restoral.

You mention that you removed and reseated the module. That is awfully strange as I would expect the panel to not recognize a module was connected rather than report errantly.

Are you powering any ancillary devices off the 2Gig panel terminal block?

Be sure to have suretycam reset Q44 to 0, then optimize panel

Before making the switch, be sure to let us know you are going to do a Panel Swap, by emailing us at customerservice@suretyDIY.com or Live Chatting us via the website during business hours. We’ll coordinate with you on pushing the back up. Loading the previous back up will include opening up Q44.

OK, it’s been a long evening and the end result? Everything is back to normal! By that I mean my cell module in my original panel is working again. I’m not sure if it’s normal, but it seems that Q91 “Select radio modem supplier” set to 0 “No radio modem supplier” was my problem. When I set to 1, the serial number is displayed correctly and cell phone test succeeds. When I set it back to 0, the serial showed the generic 1234567890… again. I don’t know if I accidentally changed that setting earlier this week or what, but I’m glad it’s working again. Oddly enough though, I decided to test setting Q91 to 0 on the APX panel and now it won’t even boot up! The display has some distorted color bar at the top and then it seems to go into a reboot loop. Both panels have 1.12 firmware, so I’m not sure what’s up. I guess this is what happens when you only know enough 2GIG DIY to be dangerous :slight_smile: Anyway, the only thing I’m missing now is the SuretyCAM logo on the panel, but I suspect that will come down soon. Thanks for all the quick replies today.

As I said in my last post, the cell module is working again in my original panel seemingly after changing Q91. Too bad I didn’t notice that sooner.

Anyway, the issue now is that it seems the panel is not updating ADC with its status. I can arm remotely, but if I arm locally on the panel, ADC does not see the status change. So, it’s like there’s only one-way communication to the panel.

I’m hoping this is just because I still have the Go!Control logo on the panel rather than the SuretyCAM logo and maybe you just need to send a signal to configure it again?