Can't add iPhone 14 Pro or Pro Max to bluetooth disarming


I’m having a similar issues except I can’t get the qolsys panel 4 to pick up my Bluetooth at all. It doesn’t show up period. I can connect and pick up all other devices and so can the panel but my phone doesn’t see the panel and the panel doesn’t see my phone.

What phone model are you using?

iPhone 14 Pro Max

Thank you, we will update the ticket with ADC

Ok, thank you

Hello @jwcsurety ! Do you have any further updates on this issue? I have a similar situation as @ImpetuousRacer I got to new iPhone 14 Pro Max’s for my wife and I. I was originally able to discover both devices however her phone connected successfully but my phone was found by the Qolsys, I confirmed the pair code was correct then pressing save to allow the remote disarming did nothing. Now the panel won’t discover the iPhone at all. I have tried all types of names on the iPhone and nothing works. This has been an issue for the past 2-3 months since the release of the new iPhone lineup. Any updates will help. It’s very convenient for the remote disarming when arriving home with things in my hand so I don’t have to rush to the panel to enter the passcode to disarm.

Same thing happened to me. Even though the phone never appears to fully connect, it’s stuck in there. You have to run the delete all bluetooth devices option and then your phone will become discoverable again.

My understanding is the issue has been fixed on iOS 16.0.3 onward. I recently tried with the latest 16.1.2 and now both phones work without issue.

So update your iOS to the very latest version. Delete all Bluetooth devices from panel, then try again and report back. Best of luck!

Okay I will try that in the morning. I will update my phone now as I’m currently on 16.1! I’ll let you know if successful. Thank you!!

Was this every resolved? Experiencing same issue with iPhone 14 Pro and changing the name did help

Make sure your iOS is updated per the suggestion here.

Let us know if you have the same issue on 16.1.2 + and what version is experiencing it.

I’m running into the same issue described in this thread.
I just got my Qolsys IQ 4 Panel up and running a couple weeks ago. I was able to pair an iPhone 13 running iOS 17.3.1, but have been unable to connect my iPhone 13 Mini running iOS 17.4.

I tried the steps outlined above where I remove all devices from the panel, and my iPhone Mini shows up, but when I try to pair it (after confirming the numbers) it just spins a progress spinner saying “Please wait” and then that message goes away and the phone doesn’t appear to have paired.

As a note, pairing the iPhone (not mini) again, after having removed all devices, does still work and pairing was successful for that phone.

Any ideas?

My wife’s Bluetooth wasn’t disarming. So I removed it and went to readd it. Experienced the same issue both with mine and hers. iPhone 15 Pro Max and iPhone 15 Pro on 17.4.

It appears to almost pair but doesn’t show up as added after. After literally like 50+ reattempts I got it to add and it takes the additional step after to select partition and details (which I didn’t get when it half connected the previous times).

Real PITA!

That’s insane that it took that many times… but I guess I can try the same. Brutal!

I felt like maybe it was helpful that when the pair window would pop up, I waited a while before hitting pair. Could have just been placebo though.

While we have not been able to replicate this issue, one user followed the below steps as a work around. Your mileage may vary.

The workaround I found is this:

  1. Click on device to pair.
  2. Click pair on both the phone and the panel when the pin code is displayed.
  3. As soon as “IQPANEL-BTD” shows up as a bluetooth device on the phone, tap on it, and it should say “Connected” on the phone.
  4. The pairing process will fail as before, however the phone will still show IQPANEL-BTD as Connected.
  5. Wait for the panel to scan for devices again, select the phone again.
  6. Click pair on both devices.
  7. Then click “Save” once the Allow Disarming box appears.

I have a ticket opened with Qolsys, I am happy to add Surety subscribers panel information to the ticket for review if you would like.

Just let me know here (no need to post actual panel data as we have that on file) and include the phone model and OS version.

1 Like

Tyler, you can add my panel info if you want, no problems with that.

As an update, I was able to finally get my phone paired. I didn’t see your (Tyler) suggestion, but I followed the advice ImpetuousRacer gave on just trying over and over again, and finally it ended up working after about 20 attempts. Wasn’t very fun, but glad it’s finally paired.

Hopefully Qolsys implements a real fix on this soon, for anyone else facing this, and just in case I ever have to re-pair or pair a new phone!

I verified yesterday that iOS 17.4.1 does not fix this problem. The workaround posted still works though.

The problem appears to be related the timing of the iPhone connecting to the panel during the pairing process. I think that’s why the workaround works, or why doing it over and over again eventually works, after so many tries you eventually get lucky with the timing and it works.

Thank you, I have submitted your panel’s IMEI to add to this issue with Qolsys

Thank you for that information. Fortunately the work around seems to resolve but Qolsys representatives have stated that the issue is being looked into as well.

I wanted to chime in that I also had the same problem pairing iPhones (a 15 pro and a 14 pro on iOS 17.4.1). The pairing process would fail.

Using your workaround instructions worked! Though, it would be great if Qolsys ultimately fixed the issue as I’m sure there are countless new users who just give up on automatic disarm via their phone because they could never pair.