Can't add iPhone 14 Pro or Pro Max to bluetooth disarming

I removed the old iPhone 13 phones and went to add the iPhone 14 phones. I go to add Bluetooth device, it finds my phone, I do the pairing process. Then IQ4 pops up the phone with option to allow or not allow disarming. I leave it at the default selection of allow disarming, and press save… then nothing happens. I press save; nothing happens.

I see IQPANEL-BTD in my Bluetooth devices on my phone, when I go to connect to it, it tells me that connection unsuccessful and forces me to remove it. I try to re-add the Bluetooth device and it never shows up. I check Bluetooth devices on the IQ4 panel, and nothing is listed. I then use the option to remove all Bluetooth devices and then search for the phone and it shows up. So, it’s like halfway connected when I try the process.

I rebooted the panel, I’m on the latest firmware 4.2.0. I tried my phone iPhone 14 Pro Max, and wife’s phone iPhone 14 Pro, both have the same result. iOS 16.0.1.

Linke to video: Dropbox - IMG_2504.MOV - Simplify your life

Any ideas how to get it to work? Thanks.

1 Like

What version of iOS were your iPhone 13s using? Are you able to re-add those normally?

We received a second report of this behavior regarding an iPhone 14 Pro, and it is unfortunately looking like the new models have a software hurdle to troubleshoot.

The first suggestion would be to follow standard Apple bluetooth troubleshooting.

  • Turn on and off Airplane mode.
  • disable bluetooth and re-enable
  • restart phone
  • reset phone settings (an option in iOS 16) this defaults everything in the settings menu and clears saved bluetooth and wifi networks.

I originally paired with iOS 15 on the iPhone 13. I no longer have them to test.
I did all the troubleshooting as suggested minus the reset because it erases the 100’s of Wi-Fi passwords you accumulated over the years.

I am forwarding this to Qolsys for review to see if they can test and identify any issues, although given the way bluetooth works, I think this is probably going to be an issue with phone software. I can’t say for certain and do not have that model of phone to test internally.

I’m not finding anything in a quick Google search that isn’t general Apple troubleshooting, but it may be good to check Apple forums for similar mention of bluetooth failure with third party devices. There may be a new setting or change to default settings impacting this.

I will follow up here with any info from Qolsys.

1 Like

Just wanted to add another data point that I am experiencing the same issue with two new iPhone 14 Pro models, so it seems to be an iPhone 14 specific issue. I did do the ‘reset network settings’ thing and it did not fix the issue.

1 Like

Thank you, yes we reported this to Qolsys and they are going to test and see if they can identify what in that model is causing the issue.

Another user has found that it may be related to special characters in the iPhone device name. This appears to only affect the iPhone 14 models.

By default it sounds like the device name is a possessive description using your first name “Jason’s iPhone” for example.

Change the name of the device to something without a special character, can you save the bluetooth connection?

Neither phone had apostrophes or other special characters unfortunately.

How about spaces? Can you try adjusting to a short one word name as a test?

very strange - I changed my phone to all-lowercase, three letters, no numbers, and it worked! My wife’s phone also changed to all-lowercase, three letters, no numbers, and it didn’t work.

1 Like

What are the two names? Can you private message that info to me?

DM sent

Can I experiment with names to see if it will add to the panel, then once added to the panel, I can change the name back on the iPhone, and should work fine?

Another user reported that changing the name allowed them to link the phone. They did not mention changing the name back. You could test changing the name back after, please let us know if you are able to get it connected and if anything changes after readjusting the name.

So I removed the apostrophe from my phone (iPhone 14 Pro Max) and it worked.
I did the same for my wife’s phone (iPhone 14 Pro) and it didn’t work. I set hers as a bunch of different names, including 1 character lower case and it did not work.

I wonder if @ cheezekurl is using the same 2 iPhone variants with same issues?

Afterwards, I changed my phone name back to having an apostrophe and connected to the panel and the name updated on the panel and connected fine.

Thank you for the feedback. There is definitely more to the issue than just the name. The activity doesn’t make a lot of sense yet. I am reporting it to Qolsys to help them identify what might be affecting this.

Just wanted to throw in another comment, having the same issue with the iPhone 14

Also would like to note, it may be IOS 16 related. I had attempted to add back my iPhone 12 after upgrading to iOS 16 and had the same issue

I tried multiple variations of upper and lower case 3 letter names and still no luck

We had another user say that they updated an older iPhone to iOS 16 and it still worked. Can you confirm the exact version number for that iPhone 12’s OS? 16.0.1, 16.1, etc.