Arm/Disarm rules not working on Alarm.com

Rules for arming my 2GIG when a Z-wave lock is locked and disarming when unlocked by user code don’t seem to work. When I lock the door manually, or using the outside Schlage button, or alarm.com, the door locks but nothing happens on my 2GIG panel. Likewise, when I unlock the door while the system is armed, nothing happens.

Rules for locking the doors when the system is armed work perfectly fine.

Can anyone shed some light on what is required for these rules to work?

Thanks!

What model of lock are you using?

I have two Schlage BE469.

I do know there are some firmware issues targeted to be fixed in the 1.13 firmware regarding the 469.

Barring that being the problem, have you tried deleting and recreating the rules that are malfunctioning?

Yes, I already tried deleting all of my rules (using Delete All) and recreating them. No luck.

The current known issue with Schlage BE469 locks and 2GIG panels (to be fixed in firmware 1.13) is that the 2GIG panel is sometimes having trouble setting user codes in BE469 locks. Are you manually entering your user codes into your locks or are you letting them be set by Alarm.com and managing them through Alarm.com?

Also, if you have a chance, can you try one more time? I sent a refresh command to your panel and I’d like to see if that helped any.

Also, are these relatively new Schlage locks? This model 469, only units manufactured after 4/21/2014 will be compatible.

Ryan - My codes were set up and are managed through Alarm.com by giving my existing users lock access. I just tried again and it still doesn’t work. Does this only work if you lock the lock in a certain manner (e.g., manually)? Or should it work no matter how you lock it?

Jason - I bought these locks roughly 1 week ago through Amazon.

Also, for the past 2 or so days, I’ve been having issues with locking on Alarm.com hanging on “Sending Unlock command”. The lock still locks 95% of the time. If I wait instead of hitting refresh, it will sometimes display this message:
“We are still awaiting confirmation from your system that your remote command has taken effect. Please check back (or refresh the page) in a few minutes to make sure your locks are in the desired state.” When I first set these locks up, this did not happen.

Interesting. From everything you are saying it sounds like signals to the lock are functioning but signals from the lock to the panel are not consistent. (disarm, arm, etc. all reliant upon status signals)

How close were these locks to your panel when you learned them in? They should be within 3 feet and remain there until your panel displays the type of device.

When I set these up, my panel was about a 10 ft somewhat straight shot to the back door and an 18 ft straight shot to the front door. I didn’t know about the 3 ft rule.

Here is what I’ve done today (giving 5-10 minutes between any alarm.com actions) and it’s still not working:

  1. Moved my panel and plugged it in next to a lock.
  2. Held panel about 1-2 ft from the lock
  3. Removed my back lock from the z-wave network.
  4. Added the lock back to the network.
  5. Sat the panel roughly 3-4 ft from the lock
  6. I then added my lock access back through alarm.com.
  7. Verified codes are working.
  8. Verified locking/unlocking works on alarm.com.
  9. Deleted all rules.
  10. Recreated rule to arm system when door is locked. Still doesn't arm the system if I manually lock, lock by Schlage button or through alarm.com.

On your account I see almost no events in the event history that show the door was unlocked by a specific user. Almost all the Unlocked events just say “Unlocked”. When you unlock the door by entering an Alarm.com user code the event history should say something like “Unlocked by Joe Smith”. If 2GIG and Alarm.com aren’t aware that a valid user code was what unlocked the door then the rule will not work.

Search your event history for the word Unlocked. It looks like the last time it was unlocked by a user code was on 2/20.

I realize that doesn’t solve or even fully explain the problem but it’s progress. We have to figure out why 2GIG and Alarm.com aren’t aware that a user code unlocked the door. It sounds like a problem with Schlage/2GIG/Alarm.com not having synchronized user codes. We have seen this problem with Schlage locks before, although then it was with a BE369. See this post:

Also, FYI, Schlage locks are notoriously bad at compatibility with 2GIG and Alarm.com. Almost all the Z-Wave lock problems our customers ever have to deal with are Schlage related. It seems like as soon as one Schlage issue is fixed another pops up. Yale and Kwikset do a much better job at Z-wave compatibility. Schlage seems to only care about Nexia compatibility.

Makes sense regarding it not saying “Unlocked by…” in the history being related. The few times where it shows a user or slot # are when I was troubleshooting this issue locally on the panel:

I haven’t really been testing the Unlock/Disarm rule much. I’ve mainly been focused on the Lock/Arm system rule.

When this rule is properly setup, does it act on all “Locked” events? Or, does it look for the door to be manually locked, locked from the outside or locked from the outside using a user code?

Also, if I can do all of this locally by setting Q79 back to (2) can I replicate these rules on the panel?

Yes, the “arm when locked” rule should work whenever the door is locked. Good point, I was focusing on “disarm when unlocked”. I guess setting Q79 to 2 and seeing if you can make it work that way would be an interesting test. However, doing that will remove all your ability to program 2GIG rules on Alarm.com.

I changed Q79 for z-wave to (2).
Deleted my secondary users.
Gave my master user a lock pin. Tested with the master user… The “auto disarm” option appears to work locally.
I don’t see a way to create a local rule to arm the system when the door is locked. That is a limitation.

Strangely, I can still lock/unlock through alarm.com even though I shouldn’t be able to. It has been 15+ mins and I still can.

I deleted my secondary users from alarm.com so I’m going to test from scratch as my master user.

You should still be able to control devices through ADC, just not program ADC rules.

If its alright with you, I’d like to remotely change your Q79 back to 3 so that our ADC partners can assist with troubleshooting.

Amanda it should already be on 3 but please feel free to, just in case.

Thank you all for assisting so far.

ADC has sent through some additional commands. Can you test to see if the issue has been resolved?

Amanda, I’m not seeing any changes. Alarm.com still doesn’t show who unlocked a lock, I still cannot arm the system by locking my back door lock and I still cannot disarm the system by unlocking the lock with a user code.

Is there any feedback from ADC on this?