Alarm app constantly giving loss of signal warnings

Wondering if there’s any way to stop this… app is almost constantly giving me warnings about loss of signal from various devices, that seem to be mostly false. For example, I just got a message that one of my thermostats is offline, but when I check it on the Ecobee app it is clearly working normally. This also occurs with various motion sensors and other things, and often they pop up when I’m arming or disarming the system (e.g. - Arm Away… “Bedroom Motion Sensor is offline”).

No idea why this is happening. I’m guessing some transient interference? Regardless, I’m sick of having to clear these notifications all the time. Should I just delete the thermostats from my app? Is there something else I’m missing? I have excellent wifi coverage in my house, no dropped signals, etc.

Offline malfunctions are a common status, but the cause and resolution is different based on the type of device. It is not all the same cause. Ultimately what it means is that the device is having trouble communicating, but different devices have different communication methods.

For sensors and Z-wave devices we have a guide below going over the common causes. These are the most common offline statuses, and for sensors it often a combination of factors, such as range or attenuation compounded by lower battery levels (even before a low battery status).

For Ecobee, it has been a common report that Ecobee reports offline intermittently. This usually appears to be due to intermittent wifi loss on the ecobee thermostat. This is a back-end integration where ecobee sends those statuses. Quick drops and restorals can happen for various reasons. Do you have multiple access points or a mesh wifi system? What model router do you use?

You can turn off all malfunction notifications by editing the system actions to watch notification in

Thank you - for my various sensors (motion sensors seem to be the most problematic) I’ve tried all of those steps and they still trigger multiple daily notifications.

Regardless, your last line (“You can turn off all malfunction notifications by editing the system actions to watch notification in”) is what I was looking for I think - no point in receiving all of these notifications which aren’t even accurate, so I just turned them off! Thanks!