Adding T3000 to IQ Panel 2

I removed all of my Zwave device including both on my T3000 thermostats from my IQ Panel 2 this weekend and they were removed successfully. When I attempted to re-add them, the IQ Panel 2 ends up timing out with a 514 error (this is with no other Zwave devices added). The thermostat though says it was added successfully and when I look at the status, it shows the node number and instead of “Add” on the Network screen it shows “Remove”. Also I remember seeing the T3000 show a message after it was added to the panel about Smart Start but it disappeared before I could see anything else.

Any idea what I can try to get the thermostats added to the IQ Panel 2?

It is rare, but whenever I have noticed inconsistencies in how the IQ Panel pairs Z-wave devices it is generally resolved by a panel reboot. Go into settings > Advanced settings > Panel Reboot.

Then Clear the thermostat using Clear device, followed by Add Device to pair it again. Does that fix it?

I rebooted the panel and tried to add the thermostat the same thing is happening. The thermostat will say Network Config in Progress with a DSK number, and then it goes back to the main screen. When you look at the Network Settings it shows it’s in the network with a node number. But then the panel times out and it does not show it being added.

I just want to be absolutely sure, does the panel pick up the device when trying to use Clear Device instead of Add Device?

Keep in mind Clear Device must be used even if the device is not listed in the panel: Z-wave is a two way communication method in which the individual devices save parent network info.

This is not the same function as Remove all Devices. Removing all devices does not do the same thing.

Yes. Clear Device works, I used Clear Device to remove the thermostat. The panel shows the device was cleared successfully and the thermostat showed that it was removed and ready to be added to a network again. This same thing occurs for both of my T3000 thermostats. I’ve been able to add other switches, fan controllers and locks to the panel without issue. Seems to be something specific to the T3000.

Very strange. Can you check under Settings > Advanced Settings > Installation > Devices > Z-wave Devices > Z-wave Settings.

How many thermostats are allowed? Make sure this isn’t set to 0. Also try editing that value and then heading back into pair mode.

How far away are the thermostat and the panel when attempting to pair?

There were 10 thermostats allowed. I changed it to 5 and the try to include the thermostat and it was the same result. Thermostat thought it was added but the panel timed out.

Regarding distance, I took the thermostat off the wall and had it next to the panel this time when trying to include it.

Since these thermostats support the new S2 security mode could it be something with that. I tried to add the device using the Smart Start method last night I got further than normal, it showed the device in the provisioning list but it said it was not connected to the network. I also recently upgraded the OS to 2.5.0.

I haven’t heard this specific report before but I would assume that the firmware update is the catalyst for this. It is definitely possible that new changes are causing an issue here.

Can you confirm the Z-wave version details for your panel? Go to Settings > Advanced Settings > About > Z-wave. What are the Z-wave Firmware Version and the Z-wave API Version?

Zwave Firmware 6.81.03
Zwave API 6.04

Thank you. I know we are seeing an issue on Z-wave 6.81 with Schlage locks pairing and functioning on the panel.

It may be that there is also a bug going on with the Tstats. I have sent this info to Qolsys. Hopefully they will be able to confirm whether or not an overall issue exists quickly. I will follow up here with their response.

Sounds good.

The only other issue I experienced was making the Qolsys IQ Panel 2 secondary to a SmartThings hub using the guide found here. I was able to get the panel and SmartThings connected but when the devices started to transfer to the panel, the panel errorred out.

This brings up a question, if I were to make Qolsys IQ Panel 2 secondary to SmartThings, would the T3000 and remote thermostat sensors need to be paired with SmartThings first or would they be incompatible with this configuration?

We are checking with regarding the RTS, but I don’t believe that would be supported officially.

Regarding the Tstat and S2 security, we may be able to help by entering the DSK manually on our end and then you would be able to try pairing the device.

Could you provide the full DSK number? It will be a long string of digits and dashes. We will then confirm when entered and ready to try pairing one more time.

The T3000 and RTS would need to be paired directly to the Qolsys panel, not the ST Hub.

I’m not sure if this is the DSK or not but this is the number above the Zwave logo on the tstat. (removed)

@tyler…How do you pair the T3000 and RTS to the Qolsys panel if it’s a secondary controller? Or is using the Qolsys panel as a secondary controller with the T3000 and RTS not possible?

How do you pair the T3000 and RTS to the Qolsys panel if it’s a secondary controller? Or is using the Qolsys panel as a secondary controller with the T3000 and RTS not possible?

Per ADC this setup is not likely possible. They would both need to be learned into the Qolsys panel. You could always try to learn them into the ST hub, then pair the Qolsys panel as a secondary controller, it would receive the device list from ST, however it is unlikely the RTS link with the tstat would be unaffected.

The DSK number will typically be a long string of 5 digit parts: xxxxx-xxxxx-xxxxx-xxxxx-xxxxx etc.

I figured that setup would not be possible but thought I’d ask. I might try what you suggested. I know the tstat and RTS can be paired into SmartThings and they do work. But the comms with ADC and the tstat/rts is definitely questionable.

On the tstat, where would I find the DSK? On the back of the tstat, there’s only that number and a PIN. Is it available in the menu?

The DSK is listed in the QR code, and the first five digits when the Tstat is in the pairing process.

However after talking with ADC and going over the info from your system, something interesting was found. We don’t actually see record of the system successfully entering Add Mode the last few days. The panel is simply not reporting it, and that may be indicative of a problem with the radio right now.

Usually a reboot will take care of an Issue with the Z-wave radio waking. Would you be able to try a “Remove all Devices” which will reset the radio? You would then need to clear each device and add them again. This reset may be necessary.

After, if the thermostats still don’t pair appropriately, please try initiating the add-mode remotely through the ADC Add Device option in the app. Your panel does appear to acknowledge the Add Device command.

I rebooted the panel, used Remove all Devices and then try to add the tstat and the result was the same. The tstat thought it was added but the panel timed out. I then removed the tstat using the Clear Device on the panel.

I then used the app to Add Device, the panel went into Searching for Devices dialog box and the tstat thought it was added again, but the panel timed out. Again I cleared the tstat using the Clear Device on the panel.

I then attempted to add my door lock to the panel, and it was added successfully. There was some popup message about S2 security but I don’t think my Schlage lock supports S2 as it’s a few years old.

Interesting. Alright, I think we’ll definitely need to investigate this as a potential bug with Qolsys, based on what you are describing. When did you update to 2.5?

Can you check the firmware version of the T3000 thermostats?

Press the Dash button.
Select ABOUT.

When looking for the general firmware of the thermostat, refer to the MFW version.

I upgraded to 2.5 last week Thursday I believe.

The tstat firmware MFW version is 1.2.