ADC-T3000 Calendar Won't Sync

Hi!

We had a tornado a couple weeks ago knock out our power to our home for 3 days. After power came back on, neither of our ADC-T3000 thermostats’ calendars will sync. We have on upstairs and one downstairs.

The thermostats accept commands on the unit themselves (I can turn the temp up/down to heat/cool, etc). They accept commands through alarm.com and our phones’ alarm.com apps (can set temp remotely).

But the automatic schedule doesn’t work.

I have tried a few things, including changing the schedule on alarm.com, copying one schedule to the other and saving; switching from a 5&2 day schedule to 7 day and back to 5&2; switching from 2 settings/day to 4 settings/day and back. None of it worked.

Need some advice!

The first step I would try is a power cycle of the thermostat. Pull it off the wall, remove batteries, wait about 2 minutes, put batteries back and plug it back on the mounting plate. Edit and resave schedules in Alarm.com. Does the problem continue?

If so, I would recommend deleting that affected thermostat from the panel, wait 5 minutes, then relearn the thermostat.

Reconfigure the schedule for the new thermostat in the app. Does this resolve the problem syncing?

Ok. Power cycle didn’t work.

I’m going for the delete and re-add method right now. I’ll update after.


I am unable to remove the device in the alarm.com panel. I get an error (see screenshot).

The thermostat is on and the screen works. Calling the number in the error code sent me back here.

What should my next step be?

Note that the schedule will not automatically be triggered when first saved. It will only ever change based on a scheduled temperature at a time when a change would occur in the schedule. So if your schedule is set for 75 now, but changes to 78 in two hours and you enable the schedule right now, it will not follow the schedule until that change in 2 hours. Be sure to wait until the next time the schedule should change to determine if the power cycle has an effect.

Steps to locally control the removal and add process are linked above, adding them here:

Sending commands in Alarm.com is just putting the panel (in the case of the Concord, the ADC module) in inclusion or exclusion mode, if you do that successfully you still need to perform the steps on the device itself to clear it. We usually recommend using the local steps to avoid time-out confusion. Please try the device removal steps in the link above.

On the temperature change, I have been testing it to trigger a change in temperature whenever I check. That’s not the issue.

Ok, I’ve locally removed, reset, and re-added my downstairs thermometer. The instructions necessitate using a red button but my button is black (just a heads up). I’ve followed all of the steps and now my thermostat says it is connected, but not to the same node as it was before.

Alarm.com online panel does not detect it. No commands going through.

Per the linked instructions, it looks like I need y’all to send a Z-wave Network Rediscovery command on your end.

Or I need y’all to tell me how to get the Alarm.com online panel to recognize the new device. I tried deleting the old “Downstairs thermostat” on Alarm.com and it has failed to delete it repeatedly. I have tried adding a new ADC-T3000 panel and that has failed repeatedly.

Stuck.

I’ve sent a command to check the latest equipment list and sync with ADC. I see the new device now in your list and it looks like it was added successfully.

You should be able to view that thermostat and set schedules for it.

Just to clarify, when you save the schedule and turn it on, the thermostat won’t immediately change. That will only happen later at a change point in the schedule.

Does the new schedule work as expected?

There may be some general communication issues with the Z-wave network. I have sent a rediscovery command to the module but that command appears to have failed. I am trying to send it again to make sure Z-wave signal routes are set properly.

Hey Jason, thanks for the help.

I can confirm I can see the thermostat, but that schedules still do not work for it. The new schedule does not sync to the thermostat as expected.

What is the next step?

At this point the panel needs to be power cycled, then a Z-Wave rediscovery re-run as the rediscovery commands are not taking.

To do so safely,

  1. disarm the system
  2. Disconnect AC Power
  3. Disconnect Internal battery
  4. Wait about 5 minutes, then power up in reverse order.

Once done, let us know and a rediscovery can be re sent during normal business hours.

When troubleshooting, you may want to place your 24/7 professional monitoring account on Test Mode during troubleshooting to avoid any false dispatches.

You can do this by calling monitoring operators directly at 855-348-0367 or from the Test My System tab in the System Manager section of your Surety account.

Ok. I’m going to attempt this in the morning (around 8am Central) and will let you know when it is done.

Hey, I’ve just completed the power cycling as described. Can you run the rediscovery, please?

Network rediscovery has been sent. This can take several minutes to complete.

Unfortunately the Z-Wave Network Rediscovery is not updating. We have reached out to ADC to resolve.

To confirm, neither of the two TSTATS are following the schedule as intended, correct?

A couple additional questions:

  1. Do the schedules never work, or is it intermittent?

  2. Did the schedules work before the power outage?

I’ve sent some diagnostic signals that I think will help alleviate the trouble but they will take a few moments to complete. In ten minutes or so, test for functionality with the schedules. You may need to pause the schedule for a couple minutes, then unpause.

Thanks, Tyler. I can confirm that the two TSTATS are not following the schedule (as of 90 mins ago).

The schedules worked flawlessly before the outage. The outage occurred about 2.5 weeks ago.

I will try pausing the schedule and then checking again in 20 mins.

They are working with the schedule as of just now. I went to pause them and they had already been updated to the new “test” temperature. I will try changing the temperature again in 20 mins at the half hour mark and will update.

Confirmed fixed.

For future reference, what happened on your end that ended up working to reset it?

Had to have some special diagnostic commands. Unfortunately, this is something that can only be done by ADC via special request.