2gig GC3 keeps losing zwave control

Does anyone have an issue with their GC3 losing connectivity with their zwave devices? My sensors work correctly but my locks and lights seem to lose contact with the panel frequently.

How often are you losing signal with your locks and your lights? Have you always had intermittent connectivity issues with these z-wave devices?

As of this time Kwikset locks are the only ones that have full compatibility with the GC3.

Have you added anything new to your system recently?

How much distance is in between each of your z-wave devices?

I have two GDO units, both close to the panel, and the other day my farther one passes connection test, but doesn’t respond to the commands. I’m not sure what’s going on with it. It doesn’t beep like it’s trying to close and the software isn’t sure why it’s not working. No solution yet.

I have Schlage locks. I have had these issues for the most part since I installed it a couple months ago. I have added nothing new since and the devices are all close to the panel.

I have Schlage locks.

These will likely see a few issues here and there until resolved in firmware. Upon release of the GC3 only Kwikset models were explicitly named compatible by 2GIG.

We’ve seen some irregularities with the GDO operation as well, though they have been accessible in ADC. See this post for more info.

I’m a dealer/installer (this is the best/only? GC3 forum out there) and used the GDO because they said it would work with GC3 at training a few months ago (though sadly…very sadly, there’s no button or status on the GC3). It has worked perfectly until it just stopped the other day on my own garage. It shows that it’s connected, but I’m not sure what’s going on. I’ll just have to get on a ladder and power cycle it and see if that helps.

Z-wave garage openers are tricky in that a garage can be the worst place in the house to place a Z-wave or other wireless device. At least it is in mine. Signal problems can be prevalent depending on the amount of metal nearby and how many other Z-wave nodes are around. It just kind of depends on the layout.

I’m a dealer/installer

Do the panel diagnostic counters indicate failing signals? We haven’t really heard of the GD00Z just not working through ADC with the GC3, so I would initially work under the assumption the issue is something local.

It has always said signal was strong. Since I had no problem for a few months with it with the GC3, I’m not sure why it stopped. When it wasn’t working, it still passed the signal test. I’ll check the counters, but for some reason it just wan’t responsive and the other one worked just fine.

I have been having z-wave issues with my GC3. I have noticed 3 different times that a sensor would not respond. I first noticed my kwikset deadbolt not reporting that it was locked. The next morning, I heard the alarm reboot (system disarmed/ready to arm announcement) and then the z-wave started working again. I had an issue controlling a light one night and then it resolved itself the next day.
Just now, I realized my sundown schedule to turn on my lights never happened. I attempted to use the website, no response. I went to the panel and all z-wave devices are not ready. When trying to do a network test, it never returns. I finally changed a loop on a non-monitored zone to force the software to restart and that fixed my z-wave issue.
Does anyone know if there 2gig is aware of an z-wave not responding issue?

So your description is exactly what I experience, just with different equipment. I recently took 3 light controls offline and added a new GE one, that seemed to stabilize the zwave network. Before that my Zwave would lock up and I would just have to wait until it rebooted itself. Either way, this is a big problem and needs to be addressed in a firmware update sooner than later. I now have 3 light switches that were perfectly good with a GC2 and now useless with a GC3.

I will note that I previously had the original version GC1 (“emergency” button version) and never had issues with z-wave commands from alarm.com to these same devices. This leads me to believe it is the panel having issues.

After installation of the devices, have you performed a network rediscovery? This is a necessary step whenever new devices are added. A network rediscovery maps appropriate communication routes for Z-wave devices. A network will typically work for the most part without doing a rediscovery, making you think everything is fine, but a number of seemingly isolated problems will often result.

General improvements are certainly needed though. We’ve discussed with 2GIG and will bring up these descriptions as well.

I finally changed a loop on a non-monitored zone to force the software to restart and that fixed my z-wave issue.

So a restart of the security process by itself (no panel reboot) resolved the Z-wave network issue you noticed?

What model of lights do you use?

I now have 3 light switches that were perfectly good with a GC2 and now useless with a GC3.

What model of lights are these?

Ok, I think the network rediscovery may have been the issue. I reinstalled all of the light switches and rediscovered after each one and 24 hours later things are still stable. Hopefully that was the issue. Now the only issue is my Schlage lock, I can remotely lock/unlock it, but on Alarm.com I have it set where it should disarm the alarm panel when you unlock it, that doesn’t seem to work. My deadbolt Schlage on the front door works properly, any ideas?

Currently, Kwikset is the only officially compatible z-wave lock with the GC3. In our experience there is no guarantee with Schlage locks working properly with the GC3.

-Which model of Schlage is it?
-How far away is the Schlage from the panel?
-Are there any other z-wave devices between the lock and the panel?
-Did you bring the panel to the lock when you initially learned the lock in?

I have the FE599NX
It’s 20 feet away
Nothing in between

Like I said, I can lock and unlock it remotely from panel or Alarm.com, but it doesn’t disarm the panel.

My deadbolt Schlage on the front door works properly, any ideas?

To be clear, the “Front Door” is successfully disarming the system, and is a deadbolt? And the other door lock is an FE599NX Lever lock, and is not disarming the system?

If that is the case, I do not see any panel users listed when the FE599NX is unlocked. Keep in mind the rule will only work when the lock is unlocked locally via a user code. If you do not punch in a code, the rule will not trigger.

Can you verify which lock is having trouble? I do see rules for both but based on history it looks like the Front Door was tested more than the other yesterday.

If the above is true and you in fact are using a user code to unlock the FE599NX, this issue seems remarkably similar to an issue we saw with the 2GIG Go!Control panel which required firmware 1.13 to resolve. The 2GIG Panel did not receive confirmation that a user had unlocked the door, only that it had been unlocked.

Yes, front door is a deadbolt and successfully disarms system. And the other is a lever lock that doesn’t.

I can verify that it is the FE599NX that is having the issues, and I am punching in a code to unlock the lock. In my old home I had the old 2GIG controller with the same brand of lock and this worked fine. I understand it may be a firmware issue.

If you wouldn’t mind as a test, could you either use a code set for a user other than your primary code, try unlocking the FE599NX door a few times. Try it with every code that has access (if you only have one code with access, try adding a new user as a test.)

We would like to see if the unlock events report differently at all depending on the user.

Ok, I have two codes I believe, maybe three. Shall I set the alarm first?

If you would like, primarily we just want to see how the unlock event is reported