ZWAVE Light Switch Not Available on ALARM.COM

I replaced a bad Zwave light switch in my shed. I was able to remove the bad one and add the replacement in the 2GIG control panel. It is available in the CP and I am able to turn it off and on. However, it has still not shown up on ALARM.COM I looked thru the forums and one suggestion was to run a cellular test. I did that (12 hrs ago) but it is still not showing up, Any suggestions is greatly appreciated.

When adding a new Z-wave device, there can be a delay in when the panel syncs that device with If you notice a lengthy delay you can force the sync using a tool in the system manager.

Visit your system manager here and use the Sync Z-wave Devices with option.

Thx Jason. FYI. I followed your directions about 4 hrs ago, but still not appearing. Should I remove it and readd?

Yes, if the device sync did not work, remove and re-learn the device.

What model of light switch is it?


I see a new Z-wave light added this afternoon. Is this issue resolved?

I had another switch to quit. So I tried removing and readding. So neither is showing up on alarm app

So that we can best assist, can you provide the node IDs of the any Z-wave devices on the panel which you do not see in

My mistake. The 2nd one did show up. The 1st one still has not. I will remove and readd over weekend. Thx so much for help. I will keep u updated

Update. So I purchased 2 more switches. I replaced one and it’s called garage lights. Install went fine and it showed up. I then replaced the shed. I can operate it from the panel , but this will also not showing up on alarm. Com. Very puzzling.


How far was that switch from the panel when added? Even when requesting an updated device list from the panel, the panel is not sharing that device node data.

The steps I would take:

Delete that Z-wave device from the panel.
Reboot the alarm panel (Settings > Advanced Settings > Reboot)
Bring the panel to within 6-10 feet of the switch and relearn the switch.
Move everything back to permanent spots and run a network rediscovery.

Then, if it hasn’t updated in ADC, wait a few minutes and run a Sync in the system manager.

Ok. Thx I will follow your instructions this evening But the times I have added the switch to the network, I put the alarm in test mode, dismounted it from wall, and took it to the shed with the power adapter to add device . I am able to turn on and off the lights via the panel after it was remounted in house. Just don’t show up in

Hey Jason. Followed instructions but still no luck. I then took one from house to shed, installed it and renamed. I then took the one that was in shed, used it to replace one in house, removed and readded to network. All is now working. Thx for the help I do appreciate it.