Z wave switch on panel, Not on app

Got a couple of GE/Jasco outdoor z-wave switches that show on my Iq 2+ panel, but do not show up on app or Alarm.com. One switch has been installed for some time, the second switch was installed a few days ago. Can control both from panel. Any ideas? Thanks

A delay can happen sometimes if the panel does not update ADC with the new device list. In the Surety System Manager you can send a command to sync up the panel Z-wave device list with Alarm.com. Try sending that command and wait 5-10 minutes. Any change?

Unfortunately no change. Sent sync command, with no change, then subsequently rebooted panel, and sent sync command once again with no change.

What are the node ids for those two devices?

It looks like you may be using Smartthings as well. Are these enrolled into the Smartthings controller, then shared with IQ Panel 2+?

Node id 33 and 46

Node id 33 was enrolled on the IQ panel and then shared from IQ to smartthings

Node id 46 was enrolled only on the IQ panel, it was enrolled Post-sharing of z-wave devices with smartthings.

I have deleted and added back the device that was node 46 via the panel. Refreshed the mesh and tried the sync command from the Surety system manager page several times. Still no ability to add automation, as devices continues to be absent from alarm.com

To isolate it as a potential issue, can you remove the Smartthings controller link and reboot the IQ Panel 2+, then remove and re-add the devices in node 33 and 46? Wait about 5 minutes in between clearing them and re-adding them.

That fixed it…kind of a bummer, as it was a pain to add the ST hub as a secondary controller, and it allowed me to leverage the zigbee ST water sensors with a Dome shutoff linked to the IQ panel. May add it back…
Thanks for your help.