Z-Wave Devices not Pairing with Qolsys Panel

My current panel is a replacement for a defective one

On the old one, I was able to use a z-wave light switch without problem, on the new panel, I am able to pair the device, but I am unable to (de)activate the light switch and it doesn’t show up on the alarm.com web-ui list of devices.

I’ve tried clearing and adding it multiple times, but still see this issue.

This is the switch: https://www.amazon.com/Aeon-Labs-DSC06106-ZWUS-Z-Wave-Energy/dp/B007UZH7B8


The device in question is listed as officially compatible through Qolsys and Commands have been run in an attempt to sync that device with Alarm.com. However, the device is still not populating.

To clarify, is the device currently enrolled in the panel or was it removed?

If removed, first clear the device from the network (Settings -> Advanced Settings -> Installation -> Devices -> Z-Wave devices -> Clear Device) then add the device back into the network. Then, be sure to run a Network Rediscovery (Settings -> Advanced Settings -> System Tests- Z-Wave Tests -> Rediscover Network)

Does the enrolled device show up on the panel? Are you able to toggle the switch on/off from the panel?

Once the device has been re-learned into the panel and if the device is still not functioning, please confirm so remote commands can be re-run.

The device was still enrolled in the panel.

Today I did the clear device and re-added it and then did the network rediscovery as instructed, and it is currently still not able to be switched on or off.

I do currently see the device on alarm.com, but it also will not turn on or off from there.

I am able to “get status” from the panel, but I cannot turn it on or off from the panel (it just shows the spinning icon until it times out).

From the “z-wave test” screen, my other three devices pass, but this one never comes back with a pass or fail status, it just waits until it times out without any sort of status.

After performing the steps to Clear/Pair and network rediscover, I am able to confirm that the device is populating in ADC. Commands have been run to sync the device with ADC, can you confirm device functionality?

Hi Tyler,

I’m still unable to change the device state from either the panel or the alarm.com web ui… I am still able to get the current state of the device from the panel (if I manually switch it on and off, the panel will show me the correct status on query).

How far away is the switch from the main panel? From the other zwave devices, specifically the T2000s?

How far away from the panel was the device when it was learned in?

It was about 25 feet away from the panel originally, but since I started trouble-shooting it (before clearing and rediscovery), I plugged it into the outlet next to the panel.

The thermostats are actually model CT101, they are each about 15-20 feet away away from the panel - they and the z-wave door lock seem to work fine.

The thing that is most odd to me is that this seemed to work fine with the original panel, not sure why it doesn’t with the replacement one.

I do have my old razberry z-wave controller I can try with the switch if necessary to verify that it still works, but I’ll wait to hear back from you before plugging it in and doing so (since I’d need to clear the switch from the panel first).

Testing it on a different controller wouldnt be a bad idea to confirm that the device itself isn’t malfunctioning. Let us know how it goes!

Today I tested the device with an old z-wave controller (a razberry / pi running domoticz) and it works properly.

I re-added it to the qolsys panel and did some more troubleshooting and found some interesting facts:

After a reboot, the on/off functionality works correctly for about 30 seconds directly after the reboot. If I wait 60 seconds or more it does not work…
I tested this over multiple reboots and it’s very reproducible.

My suspicion guess would be that somehow it is hanging when trying to communicate the state change to ADC - considering that the device does not get automatically added to ADC as expected when I clear and re-add it, this was what I wanted to test next.

I was able verify that the device works until the “manual phone test” completes - other z-wave actions such as locking and unlocking the front door lock also don’t get communicated and logged to adc until the “manual phone test” is complete.

To test my suspicion a little more, I disabled wifi, powered off the panel, removed the sim card, and tested the switch after rebooting… After disabling wifi and cell connectivity, the z-wave switch worked perfectly for over 20 minutes.

After rebooting with only wifi enabled (no sim), everything seemed to work normally from the panel, including the z-wave switch, but none of the z-wave devices transmit their activity to adc, and none of the z-wave devices function from adc (such as the door lock), but overall panel status is communicated to the adc activity log.

After installing the sim, it’s back to the original state where the z-wave switch status only works for about 30 seconds after a reboot (other z-wave devices appear to work normall).
The dual path wifi test and cellular tests run successfully.

Hopefully this information helps troubleshoot from your side / adc!

Thank you for testing! Looking at this, the switch you are referring to is a switch/energy meter, and I am curious if that may be influencing this.

I have one of those Aeon Labs switches here and will see if I can reproduce what you are seeing at all today. I do see a malfunction listed for that device in your account now.

Hi Jason, is there any more feedback as to this issue?


Unfortunately I was only able to replicate what you are seeing somewhat. The switch never loses functionality on our test systems, though shortly after a reboot commands take a great deal of time compared to normal and the progress wheel spins for a minute or so. This is likely due to background status checks on Z-wave devices and the panel fully booting up all services, connecting to ADC, etc. After about 5 minutes this goes away and we were able to control the switch pretty close to instantaneously from the IQ Panel 2 without any other intervention, as well as Alarm.com control.

Both Cell and Broadband active.

If you wait a bit after a reboot, are you able to later get status and send any commands? If not, could you provide a photo of the About page Z-wave details for your panel?

Hi Jason,

After a reboot and waiting a while (even over 24 hours) it still won’t let me change the state from the gui, but I can still get the current “status” (correctly updates if I manually activate / deactivate the switch.

I’ve attached the z-wave details, but home id seemed like it might be sensitive information, so blacked it out for this forum post.

I will check with Qolsys on this. The Z-wave firmware is slightly different between the panels we used and the info you sent, so that may be related, but we would need to verify. Will follow up when we hear from Qolsys.

Hi Jason, any follow up on this yet?

Automating this switch in relation to the fire alarm was the primary reason I went with the qolsys panel, and it did work well with the original panel (this is the replacement because of a defective lcd digitizer).

I’m really hoping we can get this resolved.

We have some follow up, but no definitive answer yet. We cannot recreate the issue you are seeing with that switch model. Qolsys sees the same as we see. The panel prioritizes ADC cell commands upon boot-up and Z-wave is delayed a short time, but it is just a few minute delay.

Still working on it and doing some testing.

Are the CT101s new? Or have you been using those the whole time? Note that CT101s are not officially supported by either Alarm.com or Qolsys and may actually be the difference maker in this case. They have been shown to have inconsistent function on other panels.

Thanks for the feedback - I thought I had the CT101s setup before as well, but just to make sure I did clear them, re-add the switch, rebooted, waited a while, and then tried it out… And it all worked!

So that’s good that we found the difference / problem, but it is annoying, considering that the thermostats themselves seemed to work fine, and everything worked from the panel when I force-disabled the wifi & lte…

Is there anything we can do about it? According to the pdf download from https://qolsys.com/compatible-devices/ the CT-100 and CT-110 are both compatible (and others from same manufacturer), can the CT-101 be added by alarm.com or qolsys?


can the CT-101 be added by alarm.com or qolsys?

The CT101 is not officially supported by any panel, so it is not terribly likely, but we can always request this.

We’ll send this as a request to Qolsys, however we could not provide an ETA unfortunately.

Other users have brought separate status reporting issues of the CT101 on other panels, so it does make sense that the failure occurs once ADC is sending communication to the devices and checking status.

Actually good news on this:

Qolsys indicated that the issue with CT101 thermostats is known and they actually anticipate compatibility with 2.1.0 firmware release.

That’s good news, thanks for checking!