Video Analytics fails to setup on camera

I went to Video > Recording Rules > (Cloud Recording) Add New Rule > Video Analytics

Video Analytics works on about half of my cameras. The other half it fails to upload.

I select a camera, it tells me it will delete all VMD schedules for the camera, then I confirm, it goes to “Video Object Detection Setup” “Please wait while we set up Video Analytics on “1. Front Door”. This may take a few minutes.”

I have a spinning progress bar. After maybe 5 minutes of spinning/loading, it fails and I receive the below error…


It works on about half of my cameras, but not the other half. (Even though it’s the same camera brand/model as the others and they are on the same firmware).


  • Mud Room
  • Front Yard
  • Side of House
  • Backyard


  • Front Door
  • Light Well
  • Pool

I’ve tried multiple times on the ones that fail and they continue to fail each time.

Thanks for the help!

Crisis averted. I power cycled the cameras that failed and tried again. They were successful after a reboot. Thanks.

I was typing out a response and I see you updated this. Yep, a power cycle would be the first thing I would try if you notice specific cameras having trouble.

First try power cycling the camera, then if that doesn’t work, try a power cycle of the router.