VDB-770 Router Settings - Flashing green light

I have tried with no luck to connect my video doorbell to alarm.com through my asus rt-ac68u router. I keep getting a green blinking light, I can see it on my routing table, but it never connects to alarm.com. I’ve even tried turning off my firewall and setting up port forwarding for the listed http and https ports on the device info tab. Everything I try doesn’t work and I always get a flashing green light. I have separate SSIDs for my 2.4ghz and 5ghz Wi-Fi bands. I have only been trying to connect to the 2.4ghz one and the only other devices connected to the 2.4ghz Wi-Fi is my IQ panel 4 and my two myQ garage openers. I have never had any issues with the router on the approximately 20 devices I have on the 5ghz Wi-Fi and never had any issues with my IQ panel 4 or myQ garage stuff on the 2.4ghz Wi-Fi.

The only way I was able to connect it to alarm.com and get a solid green light was to use an older travel router I have which I don’t want to do as a permanent solution. The travel router even had the firewall and all security settings on. I can’t understand why it won’t work with my main home Wi-Fi router. Any help would be greatly appreciated.

That blinking green light does mean that for some reason your router is not allowing the camera to connect across the internet. It only has a local connection.

Out of curiosity first, does your rt-ac68u router have a SIP-ALG setting enabled? If so try disabling that. Any change?

Have you tried connecting to the 5Ghz?

If you power it via a 5VDC micro USB and bring it closer to the router as a temporary test is there any change?

I have tried connecting it to the 5Ghz and am still getting the same response. I have also tried with both SIP passthrough enabled and disabled and neither one worked. Here are the WAN settings I can control:

Do you have any port forwarding, mac filtering, or other rules added to your main router for other unrelated devices on your network?

No mac filtering. The only port forwarding I have is to optimize my xbox and raspberry pi for some gaming. I tried to add port forwarding for the doorbell by opening up both the http and https ports listed on the device info tab, but it didn’t make a difference.

Can you try temporarily disabling the forwarding for those other devices as a test? Or could you send a private message with the ports being forwarded?

I am curious if one of the ports used for forwarding is interfering and some part of the ADC camera initial connection process is being misdirected by the router.

I would first consider things like port 80, 443, 554