V520IR firmware updated to 0101d

Anyone else notice issues with ADC and the V520IR?

Apparently the firmware has been updated from 0100e to 0101d (IP8136W-ALAM-0101d). I wonder why ADC updated firmware, was this to remove the Camera’s buggy Tamper functionality?

Alarm.com Java plugin bug?
My cam went crazy on Fri, for VMD, recorded over 300 clips nearly every min during a 5 hour period for no reason that I could discern, so I had to delete the camera, when I re-added it I discovered another issue with the ADC web interface for setting up the VMD windows… I couldn’t get the VMD windows to properly draw in IE11 (seemed to freeze on “resizing Video stream, please wait”). I was able to get the VMD windows drawn, but I had to do it through Chrome using the soon to be unsupported NPAPI java plugin (Chrome no longer officially supports Java).

Strange, ours has not updated. I will look into it today and report back.

Other noted issues with 0101d firmware…

Wireless signal strength is all over the place and inconsistent (one min its 99%, then 74%, then 50%, then back to 99%), and I am repeatedly losing connectivity, and have to power cycle. These issues did not occur with firmware 0100e.

My conclusion is this firmware is buggy, and is not ready for release.

I’ve had that 0101d firmware pushed to our v520IR.

So far I am not seeing the same issues.

(The firmware was released in effort to stop errant uploads from IR switching on.)

Looking into whether you can revert firmware, but I wouldn’t jump to conclusions yet. I’ve seen that issue described a couple times on 0100e. Factory reset usually did the trick.

So you just started noticing any issues on Friday?

Have you deleted all VMD windows and rules, then attempted to recreate the VMD windows using IE11?

Yes. No issues so far

Hmm, well here is a video of the issue

first, you will see the internet speed test (to eliminate broadband related issues)…then VMD screen on alarm.com via IE11 (newest), then the same thing using Chrome (newest)…I have tested this issue on three seperate PC’s (win7 x64 ult, and two win8.1)

When you deleted and re-added the camera, did you perform a factory reset at that time?

I am definitely not seeing the same issue in IE. (version below)

It looks like firmware actually updated on your camera on 6/30/2015. Did it function normally until Friday?


Whenever I delete cameras, I always hold in reset button, and I did it this morning prior to re-adding camera.

On the 3rd the Panel was armed away, and the VMD recordings went haywire (VMD is only enabled when panel armed away)and started recording for no reason (300+clips in approx. 5 hours). I deleted camera remotely, and this morning I reset, and re-added. I still see the VMD window issue as shown in video (which I first noticed last month) , and now my V520IR will not stay connected.

Perhaps the issue is with my network… I will look further into that

I can see back to the 19th, and there were wireless signal variations then. ~70% up to 99 to 48% on 7/3/2015. The firmware update on the 30th may be coincidental.

Just so I know, is your IE the exact same versions as shown above?

could be. I have noticed some strange issues with my network this last week, perhaps it is the underlying cause.

Just so I know, is your IE the exact same versions as shown above?


yours: .17843
mine: .17842

I believe those are the same (rather one is for windows 7, the other for 8.1)

Not sure that it would do anything, have you tried running Alarm.com in compatibility mode on IE? Maybe add Alarm.com to your compatibility view list and see if there are changes with controls.

That fixed it. (alarm.com in IE compatibility mode). Only issue is that soon as I draw the VMD window it auto saves (instead of my clicking the “save” button). Does this in Chrome too when running NPAPI mode for Java.

Alarm.com needs to fix their site so it doesn’t have to be run in compatibility mode, and they need to resolve the Java issue.

Thanks Jason.

It operates that way for me without compatibility mode (autosave). It looks like the service may be seeing some tweaks.

If you think this is bad you should see some stand alone DVR system solutions. Some you can only access with a single version of IE from 8 years ago (I exaggerate, but not much)

Can you try clearing your cache in IE and removing ADC from compatibility view settings? Any luck?

I decided to go with chrome for the time being and enabled npapi java plugin.