Update 1.6.2

I have applied 1.6.2 to the main panel. But, the IQ2, which is still at 1.5, will not upgrade, it says no control found found. Has anyone had any luck getting the IQ2 to update to 1.6 from the main panel?

I assume the issue preventing the IQ2 from working with IQ running 1.6.1 has fixed in 1.6.2, correct?

Have you tried the patch tag IQ216?

Well, i did go through the process from the main panel to update the IQ2, I did use the patch tag above and the main panel did download a patch. However, I assume after that I need to go to the IQ2 and initiate the upgrade which would then pull down the patch from the main panel? Is that the gist of it? I tried said process and the IQ2 reports no control file found. Perhaps if I could get the .gz file onto an SD card, I could make it work? It seems the problem is that the IQ2 still can’t pair to the IQ thus can’t download the patch file.

To clarify, the following should be the steps to take. Can you try these again and verify whether or not it is successful? I’ll contact Qolsys to make sure there is no issues at the moment with the process.

1- From the IQ Panel touch “Settings”
2- Enter a valid installer code (default is 1111)
3- Touch “Installation”
4- Touch “Upgrade Software”
5- Touch “Patch Tag” and enter the patch iq216 then touch Done, then OK
6- Touch “IQ2 Panel Upgrade Using Network” and the update will download
7- Press OK when prompted to send the update over the WI-FI network to any IQ2’s that are paired with the panel.
8- Follow the on screen prompts on the IQ2 to accept and install the 1.6 update. Once installed the the IQ2 will relaunch the software. Verify that it has been successfully updated by going to Apps>About. The Software Version should read: IQ2 - 1.6

Yes, I did exactly what you said, a few times. To me it seems the fundamental problem is that the IQ2 won’t remain paired with the IQ, thus the final step of distributing the patch to all registered IQ2 panels doesn’t seem to be happening.

The IQ2 behaves just like it did when the main panel was at v1.6.1 with the known compatibility issue to IQ2 v1.5.

Thank you for the replies.

Sounds like the issue is likely due to some encryption changes, but there is a work-around. Please follow the directions below from Qolsys and let us know if you have further trouble:

  1. Update main panel to 1.6.2 using the patch tag “systest162”
  2. Do two master resets on IQ2(s) back-to-back
  3. Re-connect IQ2(s) to Wifi and STAY ON WIFI CONNECT SCREEN (black background)
  4. Grab IP address by clicking network name
  5. Add IQ2(s) to main panel by using IP address
  6. Navigate to patch tag option, enter “iq216” and select IQ2 Panel Upgrade Using Network
  7. Allow patch to download and press OK when done
  8. Keep an eye but DO NOT TOUCH IQ2 SCREEN for up to 10 MINUTES

I will definitely try it and report back, and if it works will make plenty of sense to me, THANK YOU regardless. The wifi config/connect screen seems to shell all the way out to the native android OS which is likely holding up execution of the customized code that likely contains the issue.

Your advice worked perfectly. Thank you for the help. I have not fully regression tested the 1.6.2 update as it relates to the IQ2, but on the surface, it appears to be working as it should.

Again, thank you.

Thank you for the help

Not a problem, glad to hear it worked well!