Unable to include T40K in IQ Panel zwave network

One of the two T40K’s I just purchased is unable to pair with my zwave network. Whenever I go through the inclusion steps both the thermostat and the IQ Panel time out with no sign of noticing each other. This T40K’s thermostat functions appear to be working fine but I cannot get it to do anything with zwave. For what it’s worth, my other T40K paired to the same panel with no issue.

I have tried moving the panel to within 5 feet of the thermostat for the inclusion attempts. I have also tried rebooting the panel and factory resetting the thermostat. Is there anything else I can try to get it to pair?

I forgot to mention that I have also tried pairing the thermostat via smart start with no success.

Z-wave devices may still have network data saved within its Z-wave radio if used on a previous system or tested by the manufacturer, and this must be cleared before it can be added to a new panel. Running a clear device first from the panel erases that prior network link and allows it to be added again.

  • Navigate to the Settings Tray and click Settings
  • Click Advanced Settings
  • Enter your Installer Code
  • Click Installation
  • Then Devices
  • Z-Wave Devices
  • Clear Device.
  • While the panel is listening, utilize the Z-Wave devices add/remove feature (see device manual)

I tried running a clear device and triggering the add/remove operation on the T40K but the operation timed out.

I’d be very surprised if this was the case given the UI on the thermostat explicitly states it is not included in a network and that even so I performed a factory reset which the manual states will delete the thermostat from its zwave network.

If the T40K’s UI can indeed misrepresent that status of the internal z-wave data that seems problematic, especially if I am unable to clear that data.

I was finally able to add the thermostat after performing a zwave network rediscovery on all my existing devices.

I sent a command to reboot the Z-wave radio as well, usually a reboot of the panel would resolve if it was not an issue with the Z-wave device itself. Odd. Glad to hear it is successfully added though. Let us know if you see any other issues.