TS1 Porblems after attempting to flash

I have 2 TS1-1’s. On one of them I was able to update with the cable without issue.

On the second one, the update failed. I think the cable moved as I was holding it in.

Now when I boot it up, it flashes red on the home button and flashes rapidly.

I have tried powering down, removing batteries and powering back up.

Any suggestions or is this one a gone-er?

Try powering down, and reflashing it. Otherwise, it may be bricked and will need to be replaced.

Here is how I secure my cable so it doesn’t move.

I think its bricked.

2 gig or others dont let you send it to them to try to unbrick? Such a bummer.

And with the new CP3 and I would assume new remote panels, I don’t want to buy a new one right now only to replace it with the new panel.

Is the bricked TS1 still under warranty? It’s typically 1 year from the time of purchase, depending on where you buy.


No, but thanks for asking and trying to help me resolve…

I cant believe these things are just ruined. I would think someone could hook this up to something and just reflash the chip.

Wish there was a place you could send to to try. Wish 2 Gig would cover incidents like this as I am sure nothing is really wrong, but just the firmware is corrupted.

I’m sure it all comes down to cost. The shipping/repair/labor costs to attempt to resuscitate a bricked panel likely totals more than the cost of a new panel.

In general you want to make sure to never move the pins during an update. Did you try to reflash?

yes Jason, I tried to reflash. I just powered down and tried to run the program again. There is no other way to reflash, right?

No. If the software cannot detect the TS1 when it turns on, it won’t work. Just to be sure, the TS1 version of the update tool is being run, correct?

yes I ran the specific TS1 tool.

so bummed. Should have paid the 10 bucks to OTA update :frowning: