Trouble Adding Light Switch

I’ve just installed my first light switch, a Linear WD500Z-1. Seems to work fine as a standalone and does on/off/dim. However, I can’t seem to add it to my 2GIG GoControl. I am going to Services->Z-Wave-> Toolbox -> Add Devices, then I tap the Linear paddle switch. Nothing shows up to be added. I’ve tried tapping it up, down, all sorts of ways with the same result. What else can I try?

I should note I don’t have any other Z-Wave devices currently so trouble at the GoControl is not out of the question. Firmware v1.10.1, Z-Wave v2.78.


This page gives instructions on installing a zwave device.

Two things could cause this problem:

  1. Remove the device first. Zwave devices link to one network and are often tested during manufacturing.
  2. Distance. Zwave devices should be learned in within 10 feet of the panel. It’s best to use the battery capability of the panel and take it to devices like switches and thermostats.

Thanks for the quick response Jason. I did as you suggested and removed the panel from the wall to try pairing right next to the switch. Unfortunately the panel still never recognizes the switch, in either “add” or “remove” modes. It’s like the switch is not discoverable. The instructions for the switch indicate that tapping the switch should make it discoverable; am I still missing something? Thanks, Ben

I don’t see anything you’re missing. Do you have another z-wave device with which to test the 2GIG panel’s z-wave functionality? Or do you have another z-wave controller with which to test the light switch?

May be a silly question, but Q80 in programming is enabled, correct?
This question enables switch control.

Jason, not a silly question at all - I hadn’t thought to check this until you mentioned it, but Q80 is in fact enabled.

Ryan, the only other Z-Wave device I have is a CT80 thermostat, which also has never worked, but in a different way - the GoControl can see it to pair it, it just never functions after pairing. See this thread.

So, unfortunately I don’t have another known working Z-Wave device (or another controller). I do of course want to add more switches, and this one was to be the test case before I buy more of them. So I wouldn’t mind buying another switch to test if that’s what we need to do - I’m just not sure if the switch is the most likely thing to be at fault at this point.

Are you using a zwave minimote for the linear switch?


Also, you realize the current zwave version for 2GIG is 3.42? (You are on 2.78)…

Hey, that’s interesting. How to I upgrade the z-wave version? I assumed it would be upgraded along with the firmware.

Since you only have the one other Zwave device, I would recommend attempting to reset the Zwave controller, then attempt the remove, re-add.

In the Zwave toolbox choose the advanced toolbox and “Reset Controller” This will only affect Zwave devices.

Hi Jason, thanks for the suggestion, you guys are always teaching me new tricks. Unfortunately I did the reset and had the same result - the switch never shows up to either remove or add.

I’m still interested in the z-wave version question - it looks like I am on an old version, is there any way to upgrade?

Deleted. Evidently you only need a minimote for 3 way linear switches…

Hi Rive, indeed I do not have a minimote. It sounds like I shouldn’t need one for a single switch, but I’m happy to add one if it would solve my problem.


Linear switches can be kind of a bitch to pair. I have 14 of them, and recently did a panel swap; so I’ve done quite alot of pairing.

For the best success, the switch needs to be very close to the panel when you pair it. You need to take the switch to the panel or visa versa. For new switches that I’ve not installed yet, I cut the end off of a computer power cord (pig tail) and then use wire nuts to temporary wire the switch so I can plug it in right next to the panel. If your switch is already wired, then it’s easiest to take the panel to the switch. To do this, open the panel up and disconnect the power while the Go Panel is on and booted up, then it will run on battery.

Once the panel and switch are about 6" apart, put the panel in zwave discovery (zwave->add device). Then click the bottom of the switch twice, then the top twice: down down, up up. Do this then wait a few seconds, then repeat until the switch pairs. If it still doesn’t pair, then you’ll need to reset the switch. The linear dimmers have a pullout tab next to the LED. Pull it out then push it back in to reset.

This should do the trick.


Thanks for the detailed response Greg. I haven’t tried the down down up up sequence (finally a practical use for old Nintendo codes?) so I am excited to try that. Will report back.

Pairing was successful! Not sure what combination of things helped it along, but I think it was Greg’s button mashing code that pushed it over the edge. Thanks everyone for your help.

Now, the switch isn’t showing up correctly on ADC, but I see from Jason’s post on this thread that I’m not the only one.