Is there anyway to set up a rule to only set the away temperature if the panel is actually armed away?

I have a schedule set that my away hours are from 8am to 5pm, but if someone is home during the week and the panel is not set to away, I’d like to be set to my actual home temp.

Yes, actually when selecting Smart Away settings, you can select to apply the away override specifically when the system is armed away.

Ah! I was using the smart away settings wrong. Basically, I should just pick my “home” temp for all times and then, use smart away to enable the “away” temp.