Thermostat settings

My 2gig thermostat is randomly changing set temp to something in the 50s. In Alaska in the winter, this is undesireable. I’m not sure if it’s recieving commands from the site, or getting it from its own program, but either way it’s not coming from me or any program I have set up. Any idea what might be causing this?

Vivint customer?

The first thing I would check if the Temp settings are changing to something not scheduled is the extreme temperature override. On ADC on your thermostat page you can select the extreme temperature tab and set degree points where your thermostat will adjust based on outside forecast temperature. For example, I have mine set to reduce the set point by 2 degrees on days where the outside temp is 10 or below.

First of all, thank you for the replies. This was posted on my behalf by Holly the CSR.

This is a vivint system left by the previous owner of the home that I took over and is now being served by SuretyCAM.

This is what my extreme temp page looks like, which I interpret as making no change based on outside temp.

I’m at work at the moment, but I was going to try some basic stuff like fresh batteries and removing and re-adding the thermostat from the 2gig panel when I get home. I’m not sure that will solve anything because the thermostat does receive commands correctly from the web and app interfaces.

I also recently turned off the thermostat schedule because it simply wasn’t doing anything. I verified that I could manually change the set temp through the web interface, but when I turned on the schedule, it would not change the set temp according to the schedule.

In addition to extreme temperatures, another thing that can cause your thermostat target temperature to automatically change is the “Away from Home Thermostat Override” feature on the Heat Schedules or Cool Schedules tab. Your erroneous temp changes coincide with arming in away mode so that’s probably it. It looks like you have your Heat Schedule set to change the target temp to 60 degrees when you arm away. That doesn’t explain why it would be setting the target temp to something in the 50’s, it should set it to exactly 60 degrees. You can turn off the “Away from Home Thermostat Override” in the Heat Schedules tab. Or if you want to keep that enabled I suggest trying to change that away from home target temp which would hopefully re-sync your panels rules. Let us know if it works.