Smart Away Not Working

More fun with schedules and thermostats it would appear.

I have smart away set to change thermostat settings either when the system is set to “away” mode or both of the selected devices are outside the geofence “home.” Right now the system is set to “stay” mode but all the devices are well outside the geofenced area. The system is running as if we’re all home though…so wasting money.

What gives now?

Ah, the away settings options aren’t either/or. If you select both, both must occur.

Has that always been the case?

As far as I can remember that’s been the stated function.

Smart Away and thermostats UI in general went through a big change months back, so it does look different, but if I recall correctly it has never been either/or.

Either I never noticed before or I’ve been doing it wrong the whole time.

Good to know though.

There’s no indication that both conditions must be met in the UI. Might I suggest that if it’s really the case as you suggest that’s it all or nothing it should be noted clearly and unequivocally in the smart away options. It’s clear as mud right now.

I’ve suggested that a few times. There seems to be an aversion to resolutely defining certain aspects of the service - instead relying on dealers for the education, likely because smart away and the current thermostat section is new (relatively) and subject to change as the automation offerings evolve. And incorrect instructions are much worse than vague ones.

But to be honest, I’m with you 100%. The functional expectation could be explained rather easily there.

Happy to let them know it’s been requested.

Thanks. DIY is all good as long as you know what it is you’re doing lol :slight_smile:

So Jason, I’ve been playing with this since you indicated that the settings are one or the other but unfortunately my initial impressions stand.

I removed the “armed away” checkbox and only left the geofence rule in place for several days but it’s not working at all based on geofences. The only parameter that’s working is the armed away. If the system is armed stay, the checkbox for “armed away” is unselected and both the mobile devices leave the geofence by a considerable distance, the setpoints NEVER change. The only thing that works for smart away is if the “armed away” checkbox is selected and the system is indeed armed away.

Something is wrong.


Keep in mind Geofencing requires a few pre-requisite truths:

  1. The Smartphone devices must have opened and used the app, auto-starting Geoservices, since the last time the phone restarted.
  2. You must not close the service using possible third party app-killers or settings.
  3. The devices must meet the previous two conditions before crossing the Geofence.
  4. If you select multiple Geo-Devices for a rule, all must leave or enter the Geofence (per the rule wording) for it to take effect.
  5. Remaining inside or remaining outside the fence will not trigger geofence rules. The phone must cross that geofence.

If these are all true, it may be one of the devices is not being reported properly, or there may be an issue with the rule. Can you verify all the conditions above were true during testing? We will push this to ADC to look into.

I’m pretty familiar with the geo-fence features. As I mentioned earlier, their still working normally for system not set warnings when we cross the fence. All the conditions for the smart away temp rule to kick off have been met.

After disabling and re-enabling the geo-fence smart away rule it seemed to work this past weekend so we’ll see what happens. Obviously though it’s not the first time I’ve had these issues going back at least a month or more.

If this issue occurs again, note roughly the time the error occurs.

It’s not clear from above, has this issue always occurred until now or did it only begin when the thread was started?

I first noticed it when I started this thread a month ago. Can’t tell you if it was happening since the system was installed, just when I started taking note.

So today was interesting; ADC thought that both phones were out of the geofence but only one was at the time the system sent me a system not armed warning. This was at 9:19 AM this morning. I was sitting at home at the time with one of the two trigger devices so definitely not beyond the fence.

Something is awry. I can feel it.

The reason why that would happen is if one phone’s last entry into the geofence was not recorded.

There is not a time out period we are aware of, and the status of a phone having left or entered the geofence is saved when it occurs.

True enough, that is what we see in history. One device registered leaving 12/22, but not returning.

Possible causes for this:

Low power battery save mode could reduce effectiveness of location mapping
A phone being powered off when returning.
Network issues with carrier affecting triangulation.

Thanks for letting me know why it behaved the way it did. None of the conditions you mentioned were actually in place however there is another that you didn’t mention.

It happened again over the long weekend and I think I know why. It appears that when I’m actually on a phone call while crossing the geofence it fails to register. I don’t believe that my carrier, Sprint, supports voice and data at the same time unless one is connected to wifi as well. Obviously that’s not the case when I’m out driving so if I happen to cross the fence while data isn’t permitted it will never register its position.

Hmm, you’re right, that’s a good thought. I’ll double check on that but I would imagine that would cause the same problem, yes.

Other than not taking calls it’s hard to say there would be a way around that.

Unfortunately you wouldn’t be able to just have a time-out period, as it often still needs to work after extended absence.

Perhaps a check based on wifi connection and SSID?

If there was a way to set a “home” SSID that would certainly be a way to double-check the phone’s position even without a GPS verification. I don’t know if would want to use that as a primary way of controlling temp set points since if I’m out in the neighborhood walking the dogs I still want it warm when I get home but certainly as a backup method of establishing location that would be useful. I imagine it would be useful for other location aware functions as well.

Of course the no voice/data thing is carrier specific so not sure how many are actually affected by it. It’s the only thing that makes sense to me and the only thing that stands out with the two recent occurrences.

I love a good mystery lol.

Jason, I don’t think the all or none rule actually works the way you think.

Currently the system is armed “stay” but both devices are outside the geofence. Both options are selected on the smart away settings and all three thermostats are set to the away set points. If you were right, the thermostats would still be in home mode.

I’ll do some testing to be sure. These things are subject to change of course if there are enough suggestions to make it either or instead of both, but it has always been both in the past.