Skybell HD stopped ringing indoor chime correctly

I have a Skybell HD purchased from Surety in September 2017. Recently, it has stopped ringing my indoor chime correctly. The indoor chime doesn’t ring at all or has a very abbreviated chime. However, I still get a notification on my phone when the doorbell button is pressed, and I can still get video on my phone. The indoor chime is digital and is connected to a digital adapter. The indoor chime had worked properly since the doorbell was installed.

I have verified the settings for “digital” and for “indoor chime”. Both were set properly. Just to be sure, I turned them off, did a save, and then turned them back on and did another save. I have also performed a soft reset. I am still having the problem.

Do you have any suggestions for solving this problem or is the doorbell just past its usable life?

Also, do you know when a new compatible doorbell will be available?


Settings look good for the chime. Does the skybell still ring outside?

I would check the digital adapter to ensure its still attached properly and doesn’t appear damaged.

After that, I would delete the skybell from the account (through Video Device Info in factory reset the camera and learn it back in to be safe.

Then factory reset the SkyBell (hold the button down for ~80 seconds until the LED flashes yellow.) Once it reboots it should flash Red/Green indicating that it is ready to be learned in again. After setting it back up, does the chime inside function as it should?

If factory reset doesnt fix it, I would look at replacing the digital adapter before the skybell itself, given the cost and likelihood that it is the adapter causing the issue.

As for the new ADC doorbell camera, there is no release date for it. I know COVID has pushed their timetable back for it. AFAIK that doorbell is still in beta testing but we will certainly post more information as it is made available.

Thanks for your response.

The factory reset did not correct the problem. I have ordered a new digital adapter. I’ll let you know if the new adapter solves the problem.

The new digital adapter did not fix the problem.

However, I noticed something tonight that I didn’t see before – every time I press the doorbell button, the Skybell reboots (turns yellow, flashes red, the green/red, then green). I’m guessing that when the reboot starts, the signal to the chime is interrupted. Now the question is … Why is the Skybell rebooting when the button is pressed? Any ideas?

Open up the Skybell HD and take a look at the battery. Is it noticeably expanded/pillow shaped?

The battery does appear to be puffed up a bit. I’m guessing the next step is to replace the battery.

I found a battery on Amazon that appears to be compatible – Skybell HD Doorbell Replacement Battery.

Yep, I would recommend giving a battery replacement a try if it is noticeably expanded. If you have any question about it please post a photo and we can help!

Replaced the battery. First press of doorbell worked perfectly. Waited a few minutes and tried it again, this time it rebooted again. Apparently, the battery was not the primary problem.

Unless you have another suggestion, I think I will just replace the doorbell. I just need to decide if I wait for the new doorbell camera or temporarily replace it with another Skybell. In either case, I will eventually get the new doorbell camera because of its support for video analytics.

It could be the that the wiring is loose. If you push on the unit itself, not the button, does the unit reset or react in any way?

The wiring could be loose at the back plate, or be a bad connection between the back plate and the doorbell itself. You’ll want to check both.

If the wiring isn’t loose, then it likely needs to be replaced.

Still no release date or pricing information on the new doorbell camera. I know we are waiting impatiently for it.

Opened up the Skybell and checked out the wiring, made sure the contacts were clean, swapped wire pairs in the doorbell cable. Still having the reboot problem.

I have given up on the Skybell and reinstalled a standard doorbell button. Will wait until the ADC doorbell camera is released.

Thanks for your help.