Sky Bell Not providing Video

Newly installed Skybell shows good connection and has current firmware. We are getting notifications and it has save a few pictures but I am not getting Video.

That’s usually an indicator that the WIFI connection to the doorbell isn’t strong enough. From our end, your Skybell is showing a bad wireless link quality as well. Can you try moving your WIFI router closer to your doorbell as a test to see if that helps?

I understand that’s not always easy to do so I’m sorry for the inconvenience. If it’s not feasible then you might try getting a WIFI extender to boost the signal.

It’s only about 12’ away with only the one wall. It’s a fairly new ac1900 Asus router. I’m not sure what to do

I am actually seeing saved video events in your history which appear to be for the Doorbell. Is this still an issue?

Can you login to and navigate to the video page then to Saved video? Do you see video clips for that camera?

i get the video events after the fact but when someone rings the bell i cannot see video or if i click on the camera in the app it says cannot connect

Ah, ok. Well, the wireless quality is indeed reporting as poor. It is on the borderline of bad signaling, but it looks like all supervision pings have been successful so far.

Have you tried rebooting the doorbell to see if you get any improved performance?

To reboot press and hold the button for about 70 seconds until the LED flashes blue, and then release.

I would like to add to this thread. I just got the VDB105 video doorbell. It was running firmware 3038 when I first got it and the video worked from both my android and my wife’s iPhone. The doorbell updated to firmware 3049 and now I can not get live video on my android device if I am not on my home wifi. My wife’s iPhone can still get live video from both wifi and mobile data. It seems something in the new 3049 firmware does not let it connect properly with android devices over mobile data.

I just ran a test by connecting to a guest wifi that I also run at my home. This wifi network is isolated from the network that my alarm panel and doorbell are on so it would function the same as if I was connected to someone else’s wifi. When I go to view the video doorbell on my android device it works without a problem. So it looks like the issue is 100% with android mobile data and the newest firmware (at least in my case). Is there anyway to downgrade the firmware of the doorbell and prevent it from updating in the future?

Edit: To add to this issue. The setup does claim my wifi connection is poor for some reason, but I am getting 41 Mbps down, 14 Mbps up on the 2.4 ghz band in the location where the doorbell is installed. I am on 1 Gbps symetric fiber and my router shows a solid 75 Mbps down and up link to the doorbell with sub 1ms ping, so not sure why would claim the wifi is poor… I even tried downgrading the video to 480p and still can’t access it with my android device on mobile data but tried 2 different apple devices and both can access the doorbell on the same Verizon LTE data at the same location.

This is the signal strength and quality that the Skybell itself is reporting when installed in its location. Using a phone or laptop nearby unfortunately is not an exact measurement or expectation of quality. The devices have different antennae, wifi adapters, and depending on the home construction, the immediate installation location may attenuate signal.

If you see the device working when connected to wifi but not on mobile data then it is unlikely overall quality is a culprit, of course.

So it looks like the issue is 100% with android mobile data and the newest firmware (at least in my case). Is there anyway to downgrade the firmware of the doorbell and prevent it from updating in the future?

That’s a great test and it is certainly suggestive of where a problem might lie when you only see the issue on your device when it is on mobile data.

Can you let us know the type of device you are using, the carrier, and the android version currently on your device?

We’ll forward this to ADC and do some testing to see if we can replicate.

Android 9, Samsung Galaxy S8, Verizon wireless. Security patch version Sept 1 2019.

My wife is on an iPhone 6s with Verizon and latest ios version (not sure the exact number). Her phone has no issue with mobile data and the camera.

On my phone I can view recorded video from the doorbell on the app, but still can’t access the live feed when on mobile data.

I wonder if they changed the codec or stream format in the latest firmware?

We’ve tried with the VDB 105 on 3049 firmware with an S8 on android 9 and we cannot replicate this issue when connected to mobile data only. This was also on the Verizon carrier, same security patch level.

Are the two phones you are using (the S8 and the iPhone) using the same mobile service plan on Verizon? I think Verizon currently caps video streaming based on the service plan.

Do you have any problem or slowdown when streaming video from sites like youtube on your S8? Can you view 720P video from other sites?

This may seem silly, but if you reboot your phone, do you see the same issue?

OK new replacement door bell same model plugged into usb power sitting on the shelf next to the router. shows 100% signal strength. Still no video when i ring the bell or request live video in the app. I’ve tried on cellular and WIFI with my phone and on my tablet. I don’t see an option on the website for live doorbell video to try it there. My internet connection is a 1000Mbit fiber connection that should be more than sufficient. Any Ideas?

@sixtninecat what kind of mobile device are you using? I’m curious whether it’s the same as Numus’ phone.

Also, is there another mobile device you can try with so we can see if live video from your doorbell works on any device?

I have a pixel XL. But we have tried it from a few different devices

I would hesitate to combine the two reports in this thread. In your case if you cannot view live video on any device and it has happened on two different doorbells, that is likely an overall network or router issue.

Do you have a 5ghz and 2.4ghz network with the same SSID? Skybell can only communicate via 2.4.

Skybell recommends segregating the SSIDs. If they are currently the same, can you try setting a unique SSID for the 2.4ghz network and reconnect the Skybell? Any improvement?

I have good live video from from my other 2 cameras and I get good recordings from the door bell just no live video. says failed to connect. The bell is connected to the 2.4G side of the network. I also get notifications when there is motion or a bell ring.

The other two cameras would not impact or suggest video stream connectivity for the doorbell cam. The doorbell has different firmware and wifi adapter and may be affected by different router settings, etc.

It just returned “Disconnected” status when we attempt a few ping tests. Not long after it returned an “Ok” connected status on another ping test.
Now it returned another “Disconnected” status.

Are you currently working on the doorbell? If not it may be indicative of the issue if there is intermittent connectivity loss.

I was not working on it don’t understand what could cause the connection issue

Alright, we would want to isolate all potential issues, especially since you’ve already seen the same activity out of two different Skybells.

Can you please try setting a guest network on 2.4ghz in your router with a unique SSID? Then connect the doorbell to that SSID.

Please power cycle the router if the above does not cause a reboot.

Do you have any parental control settings enabled on your router? Advanced firewall settings?
Does your router have SIP ALG enabled?

Ok I bought a new router did a speed check 850 down 775 up no improvement. So i went and bought an extender and set that up still no improvement. I am out of ideas

It seems like you’ve mostly ruled out the mobile device and doorbell as the problem because you’ve tried multiple of each. Your WIFI speed clearly isn’t an issue. I assume you can see live video from your other cameras on your mobile devices?

You mentioned your previous router was an Asus AC1900. I use a Netgear R7000 (AC1900) at home with the ADC-VDB106 and it’s always worked well. What model is your new router?

This is a tough one. I’d be at the end of my rope if I were you. :frowning_face: Still not sure but we feel like the problem is most likely that the router or ISP is interfering with the live feed.

Do you have any QoS (quality of service) settings enabled in the router? Or SIP ALG enabled? These may cause problems with live streaming. If you can post a screenshot of any steaming, QoS or security setting on your router that might help. Obviously remove any personal info before posting, if you do.