Sensors showing wrong Sensor Type


I saw that you had answered a similar question ( and I’m hoping you may have some insight into my problem.

My sensors are all showing as Freeze/Water Sensors. They are not, but I cannot change their settings. The panel is an NX8V2 and the sensors are the usual entry/exit, interior follower, fire, instant entry, etc.

Do you have any idea why the sensors are showing as Freeze/Water or how I can correct them?

Thank you!

Happy to assist!

Doesn’t appear that this is related to a suretyDIY subscription, is that correct?

As such, it would be harder to pinpoint the exact reason why the Type is showing up incorrectly as I cannot see how the sensors are set up in the back end. How long have they been showing this status? Do they function as intended?

You may want to check with your service provider to get a better understanding of why they are reporting this way.

Have you tried removing a sensor and re adding it to attempt a status change with
Additionally, running a cell test may also force to update the status
Additionally, your dealer would have access to commands that could update this status as well.


THANK YOU for the prompt responses.

Yes, I just recently signed on with a local (Seattle) alarm provider. The account is brand new. My provider cannot seem to solve this problem, While searching for an answer, I saw the similar question that suretyDIY had encountered.

In addition to my gratitude, I would even consider switching my account.

The system (panel) itself has been working, without issue, for many years. It is only the monitoring that is new. is able to read the Sensor Name, and other data, but not the sensor type. See image.

I checked the zone type programming (location 25) and all 8 zones have a valid entry. They are type: 3 (ENTRY/EXIT DELAY 1), 13 (INSTANT ENTRY GUARD), 5 (INTERIOR FOLLOWER WITH AUTO BYPASS ENABLED), 25 (CHIME ONLY) and 8 (FIRE). None of them are freeze or water sensors.

By REMOVE, do you mean to physically disconnect it, or to change the programming? I have changed the entries in loc 25, exited, *44, but still not showing a real sensor type.

I also checked to make sure that the Zone Type Characteristics are not set as Local Zones. Location 111, 113, 115, etc. Segment 1, bit 8, is not set.

Can ANYBODY think of some esoteric setting that could be interfering with reading only the Sensor Type?

Thank you!


Tyler or Dexter:

Any thoughts or suggestions would be very much appreciated.

Thank you.


In this circumstance you would want your provider to request updated equipment information and troubleshoot your account to determine whether or not these sensors are actually reporting the wrong zone type/group number, or if it is a back-end issue.

Without access to the account we unfortunately could not definitively say what is going on. I’m not aware of a setting which could cause this.

If you actually set off an alarm on one of the sensors locally, does history then show the proper type of alarm that occurred in history, or does it get treated as a Freeze Auxiliary alarm? If the panel is actually sending the correct data, the alarm should show up as a correct type and may clear the issue.

Do the sensors function locally as you would expect for the zone type they are assigned in the panel?


The sensors all work locally as expected. The panel has been in use for years, only the monitoring is new.

Notifications (i.e. alarm, bypass) include the Zone Name (which are showing correctly) and Zone Number.

I have reprogrammed the Zone Types (location 25), followed by *44, several times. Have even powered down and restarted the panel.

Thank you for the suggestions.


One thing that may be causing an issue with pulling new or correct sensor data is panel programming lockout. If any of the programming lockouts in Location 21, Segment 1, Bits 5, 6, and 7, are set to ON, this will interfere with’s ability to pull the data. Even if they were turned on after getting connected to ADC.

If these bits get disabled, does that resolve it?


I’ve verified that Location 21, Segment 1, Bits 5, 6 & 7 are OFF.

I’ve looked through the programming worksheet, trying to find anything that might interfere with the ADC reporting.

I doubt, but will test:
Locations 2, 8 & 14 are set to 4. Default is 0.
Location 37, Segment 4, Bits 3 & 4 are OFF.
Location 37, Segment 6, Bit 7 is ON.

Thanks, again, for all of your assistance!


None of the programming you mentioned should cause such an issue that I am aware. The issue here is that the dealer tools contain additional diagnostics we would not have access to if you use a different provider.

One extremely important detail is what the dealer site reports as the zone type number for each of the sensors. You cannot view this on the user site. This is a big question: whether there is a discrepancy between the dealer and user website, and whether there is a discrepancy between the numbers reported and the type name displayed, as in does the actual fire zone show Zone Type (8), but still say Freeze/Water, etc? You would need to have your provider confirm this.

It might be a good idea to try making a change to one of the sensors in location 25. Change an entry exit sensor to a perimeter or perimeter to entry exit temporarily. Does this change reflect any change in after the sensor is activated and a cell test is run?

Hello Jason:

You are right, the programming changes mentioned above did not solve the problem.

But they did get me to where I was able to notice another issue, which DID solve the problem.

Short answer: ADC derives the Sensor Type from the Zone Alarm Event Code in locations 110, 112, 114… Changing the Zone Type in location 25 does not have any effect.

Thank you, again, for the assistance!


Aha, yeah that is a good find, I didn’t think that they would have custom changed all those zone types. Be careful in custom programming, as you can end up with unexpected zone functions.