Rules for Locks not Working Consistently


Several months ago, I installed 3 Yale zWave locks on exterior doors of my house, let’s call them Door 1, Door 2, and Door 3. I set up two rules in that will lock all 3 locks any time the system is armed, either stay or away. The rule has functioned perfectly, until about the last week or so, and I’ve now noticed that all 3 locks aren’t locking consistently when the system is armed. But I can’t see much rhyme or reason to it. It nearly always seems to be one lock omitted, but sometimes it’s Door 1 that doesn’t lock, sometimes it’s Door 2 or 3. Moreover, I’m not getting any kind of failure message, like it tried to lock Door 2 and couldn’t for some reason. It’s like it’s not even trying. Further, I don’t think it’s a matter of the system skipping locks that it “knows” to be locked. This morning, one of the two locks it “locked” when I armed away was a lock that I had already locked by hand upon leaving the house (confirmed in my history). It may be a coincidence, but I started to notice this problem at about the same time that the app was upgraded on my phone.

Any ideas? I’m really frustrated by the number of times I’m coming home to find unlocked doors.

Sounds more like a Zwave issue. How far are the locks from the panel? Have you changed anything in your home that would alter the signal? Maybe try re dicovering the network and see if that helps, or unistall and reinstall the locks.

My guess is that it wouldn’t have anything to do with an app update, and it is likely as Brian mentioned, a Zwave signal issue.

Do you have any other Zwave devices in your home? The locks, being battery operated nodes, will operate most of the time in a power save mode and it helps to have repeating nodes (like light switches or dedicated repeaters) nearby when dealing with more than one or two locks, or a good distance between the lock and the panel.

If that isn’t the issue, I would definitely suggest rediscovery of the network by accessing the Zwave installer toolbox and pressing advanced toolbox -> rediscover network. Test the rule for accuracy after the rediscovery is complete.

If the rule is still not functioning properly, re-create it in and save to resend it to your panel. Once sent, the rules activate locally, so if it isn’t a zwave signal issue, this should give positive results.

There are several things that can cause the power door locks not to work properly. The most common cause of a single door lock not to work, is a bad door lock solenoid). Another common problem or cause of door locks not working is simply a bad door lock switch.