Remote Temperature Sensor Un-Pairing

My remote temperature sensors seem to lately be “forgetting” that they are supposed to be paired with a thermostat (ADC-T2000) to do temperature averaging. When I reselect them, it shows up fine in the app and in the functionality of the thermostats (i.e., when it turns on and off). But after some period of time (hard to tell – definitely less than 12 hours), it’s back to square one. Not sure what’s going on but any thoughts would be appreciated.

In case relevant, I recently moved my ADC-T2000s from solely batter power to running off a transformer by hooking up the C wire. I removed them from my system and re-added them with no trouble. Not sure if that’s a contributing factor… I’ve also tried removing and re-adding the remote temp sensors but that hasn’t helped.

This would be related to local system communication. After re-adding the T2000s did you run a network rediscovery?

Which RTS did you re-add? Only one shows an install date after the thermostats, the other temp sensors show an older date.

I would recommend running a network rediscovery to ensure the best routes are learned, then remove and re-add all RTS as they do not participate in the rediscovery and must be learned in in their final location after other routes are set.

Any change?

I tried all of what you recommended and it didn’t help unfortunately. All of these problems only started after re-adding the T2000s for whatever that’s worth…

I see 4 thermostats listed on the account:

1st Floor (AC Powered), 2nd Floor (AC powered), 3rd Floor (Battery Powered, non repeating), and Basement (Battery Powered, non-repeating).

I also see 3 temp sensors. They have install dates of:

9/10, 9/7, and 8/25

It looks like the last Rediscovery occurred on 9/12.

The temp sensors, for the best chance of success, should be learned in fresh, all of them, after the rediscovery.

Over time if the temp sensors are moved, or other devices or routes change, it can affect network communication to those temp sensors. The temp sensors are not included in Network Rediscoveries. They only learn their routes at the time of inclusion.

So we know exactly which devices the issue is affecting, which thermostats are you assigning temp sensors to? Are all temp sensors going to the same thermostat?

Are all of the temp sensor settings failing all at the same time?

I assigned temperature sensors to both the 1st and 2nd floor thermostats.

I did narrow down the issue but it is now more perplexing: everything works fine if the 1st and 2nd floor thermostat schedules are off. If I turn the schedules on, then the remote temperature sensors eventually become unpaired from the thermostats. The main website also has the triangle warning indicating that communication with them was lost. Clearly there’s something else going on besides Zwave communication issues if it works fine with the scheduling disabled.

Thank you for the additional info. This may or may not be coincidental. Schedules being on will increase status messages and may just highlight problems more easily.

I’ll be sending this description to ADC to help troubleshoot, however, I must reiterate, the temp sensors must be relearned.

This is not just me saying it. When working with ADC, the first thing they will suggest is to follow the recommendation of relearning those temp sensors.

I can see they are still showing the old learn dates.

Please be sure to follow this recommendation first and let me know if there is an effect.

After relearning the RTS (again they must be left in place, along with the panel, learned in in their final location) try editing and re-enabling that schedule you want to use.

Does the RTS still get dropped? How long after enabling the schedule until it lost connection?

I re-relearned all the RTS – it didn’t help. As part of testing, I activated the schedule on the 1st Floor Thermostat and left it off on the 2nd Floor Thermostat. The 2nd Floor Thermostat’s RTS stayed paired without fail, however the 1st Floor Thermostat repeatedly lost its connection. Interestingly, the RTS unpaired immediately upon activating the schedule. I also noticed that it took a few tries to get the RTS to re-pair – I’d have to go to the screen back-to-back a few times in a row before it “stuck.” It was hard to tell how frequently the RTS unpaired, but I suspect it occurred for sure at every time point in the schedule at the very least.

The overall punch line, however, is that for some reason I can’t seem to set a schedule and have my RTS work.

Thank you very much for testing, as well as the additional info, that helps confirm an issue related to schedules.

Digging into your schedule data it does look like averaging of temp sensors is not occurring at the change times. It may be that averaging rules are just not saving properly in the schedule, or they may not have been set.

If you go into your thermostats page in, then select Schedules from the menu, select the 1st floor thermostat from the select box.

Click on or hover over the Away, Home, or Sleep schedule and the name of the thermostat. There you will see the edit pencil icon to click to select the RTS linked to that schedule type. Make sure that the RTS you wish to use for averaging is selected, then save.

If you go back into that page after navigating away, does that change stick?

Does the RTS stay connected then if you turn on the schedule?