Radio signal consistently 0/31

I have an existing system, but I needed to replace the cellular module for new service. I just signed up here, but can’t get past the cell test and the radio signal consistently shows 0/31. I have tried power-cycling the unit and reseating the module with no luck. I also tried a different antenna. Overall, the cellular signal (AT&T) is not the strongest in my neighborhood. Is there a way to check if the module is working and the reception is just bad? Are there any other things I should try?

Phone cellular service does not correlate well with machine to machine coverage, but if there is very little coverage it may indicate that carrier should not be used.

The best way to determine which carrier to use is the coverage check tool found here. If AT&T shows full coverage, then there is likely another issue occurring.

Do you have the option to run a cell test? If you do not see a cell test button when going to Security - Menu - Toolbox - Scroll Right Twice, then your panel does not see that a module is installed.

What is the current firmware of the panel? If the firmware is not 1.9.6 or higher, you will need to update the firmware before the module will be able to communicate. This is a likely issue in this case.

The cell test keeps failing, I assumed that’s from the lack of signal.
My Firmware is 1.9.6 so I should be good there.
The coverage check for my street address shows No Coverage for Verizon and T-mobile and Error for AT&T. Though Verizon has recently come into Alaska and both the AT&T and Verizon sites show data coverage for my specific address.

I would not expect to see 0/31 in the area for any carrier. Other users in the general area show quality signal. Your position may be in a poorer coverage area, but 0 likely indicates a separate concern.

Did you happen to install the module with the panel still powered up?

Could you post an image of the firmware version screen? We would like to verify that it is 2GIG production firmware.

Beyond that, generally if you see 0/31 and the cell test is an option (the panel recognizes the module) it is usually an antenna issue.

Does the antenna connector on the module feel loose at all? Are you using the antenna that came with the AT&T 3G module? It should be roughly an inch wide and four inches long. Did this antenna get snagged on anything during installation? You say you tried a different antenna, what antenna did you try? If it was an older, smaller 2G antenna, it would not work well.

I attached the requested image – the full scroll on the firmware reads: V1.9.6_PRODUCTION_EN_US…

I am fairly certain that I fully powered down (pulling the plug and the battery) when I first installed the new module, and I know I did when I tried reseating it a couple times. Both antennas are as you describe. The one came with the new board, the other was the one from the Vivint (grrr) module that I had removed.

I don’t remember snagging the antenna, but I’m starting to think that the antenna connection may be the problem. I tried putting the old module back in and the signal was 6/31–not spectacular, but it says something.


I think at this point you may wish to try a different 3G module. It is possible the antenna port has a bad connection to the board or the antenna wires are damaged.